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About the Author - Pat Geary 
Microsoft MVP - Expression Web  
Expression Web Tutorials & Templates 
Expression Web Tips 
Genealogy Web Creations 

 

 I have been involved with website 
design since the late 1990’s when I 
created my first genealogy website on 
the old GeoCities. I’ve come a long 
way since those early days. I maintain 
two RootsWeb (Genealogy) Mailing 
Lists for FrontPage and Expression 
Web. I am active on both the 
RootsWeb and FreePages Help list for 
genealogy websites as well as various 
yahoo lists for FrontPage and 
Expression Web where I provide 
resources and answers questions. I am 
still an avid genealogist and maintain 

Family Genealogy Online. Website design remains my love and I am webmaster of Genealogy 
Web Creations, which specializes in website design for the genealogist with tips and tutorials, 
resources, and css-based templates as well as a companion blog Genealogy Computer Tips & 
Tutorials.  

Expression Web Tutorials & Templates offers Expression Web resources and tutorials for all 
versions of the program as well as FREE templates for your web design use. Expression Web 
Tips is my WordPress blog which also provides short tutorials, resources, and news for the 
Expression Web Community. Counted Cross-stitch is my other passion.  

Tina Clarke who is also a Microsoft MVP – Expression Web and I have coauthored two eBooks 
you also might find helpful. Launching a WordPress Blog is a FREE eBook on setting up a 
WordPress Blog on your own domain. Migrating from FrontPage to Expression Web is an eBook 
(for sale) that can help you in the process of moving from FrontPage to Expression Web, and 
have a more standards-compliant site. 

I live in the Shenandoah Valley of Virginia with my husband, Jim, and our dog Katie (pictured 
above). Katie was adopted from our local SPCA. 

http://www.expression-web-tutorials.com/
http://www.expression-web-tips.com/
http://www.genealogy-web-creations.com/
http://freepages.genealogy.rootsweb.ancestry.com/~gearyfamily/frontpage/
http://freepages.genealogy.rootsweb.ancestry.com/~gearyfamily/expression-web/
http://freepages.genealogy.rootsweb.ancestry.com/~gearyfamily/expression-web/
http://www.family-genealogy-online.com/
http://www.genealogy-web-creations.com/
http://www.genealogy-web-creations.com/
http://www.genealogy-computer-tips.com/
http://www.genealogy-computer-tips.com/
http://www.expression-web-tutorials.com/
http://www.expression-web-tips.com/
http://www.expression-web-tips.com/
http://www.the-gearys.com/
http://any-expression.com/
http://www.genealogy-web-creations.com/launching-wordpress-blog.html
http://www.frontpage-to-expression.com/
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The tutorials included in this eBook were first published on my website Expression Web 
Tutorials & Templates and offered in the First Edition in July 2010.  This revision of the 2nd 
Edition has been updated to reflect the changes within Expression Web now that it is a Free 
program. Also includes are some of the basics for learning HTML and CSS. 

 
2nd Edition 
Published:  January 2011 
Revised: September 2011 
Revised: November 2011 
Revised: May 2012 
Revised: February 2013 

  

http://www.expression-web-tutorials.com/
http://www.expression-web-tutorials.com/
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Expression Web 4.0 
Are you new to Microsoft Expression Web? 
This article (http://support.microsoft.com/default.aspx?scid=kb;en-US;2511858) outlines the 
prerequisites for using Expression Web effectively, along with a list of useful resources you can 
use to get up to speed on modern Web design. The bottom line is that you do need to have 
some knowledge of Web design before you’ll be comfortable or effective using Microsoft 
Expression Web.  

See Learning HTML - HyperText Markup Language for the basics of HTML and references.  

See CSS Basics 

Expression Studio 4.0 was launched on June 7, 2010. The most current version is 4.0.1460.0 
which is the FREE version.  Microsoft is no longer selling Expression Web and has made it 

available to the public at no cost. You can read more about Microsoft 
Expression Changes and download the Free version of Expression Web. 

The retail version of Expression Web 4 can be licensed and activated on, 
at most, two systems, e.g., a laptop and a desktop.  If you need to 
reinstall on one of those systems, e.g., because you reinstalled Windows, 
you should be able to reinstall Expression Web 4 and reactivate at that 
time.  The Free version of Expression Web may be installed on as many 

computers as you wish. No activation is necessary. MICROSOFT OFFERS ONLY COMMUNITY 
SUPPORT WITH THE FREE VERSION. 

NOTE: If you have problems with licensing or activation issues, please see New Fix for Licensing 
and Activation Issues with Expression Web 4. 

What's New 

Some areas of work and improvement include:  

• SuperPreview online service is a beta service that extends the capability of 
SuperPreview to include support for additional browsers and operating systems. You 
will be able to see how your site displays on a Mac running Safari without owning a 
Mac. SuperPreview now includes Internet Explorer 7 as a rendering option. You will 
need to register to use this service. Expression SuperPreview Remote Beta will continue 
running as a service through June 30, 2013. 

• A new extensibility model that allows you to create add-ins much more easily 
using html, css, javascript and a manifest file (xml).  Anna Ulrich has an article on how to 

http://support.microsoft.com/default.aspx?scid=kb;en-US;2511858
http://support.microsoft.com/default.aspx?scid=kb;en-US;2511858
http://msdn.microsoft.com/en-us/expression/default
http://msdn.microsoft.com/en-us/expression/default
http://www.microsoft.com/en-us/download/details.aspx?id=36179
http://social.expression.microsoft.com/Forums/en-US/web/thread/da000eea-b7e8-461f-b64a-79fea49d8b34
http://social.expression.microsoft.com/Forums/en-US/web/thread/da000eea-b7e8-461f-b64a-79fea49d8b34
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create add-ins for Expression Web 4 at Easily create an Add-in for Expression Web 4 
with the Add-in Builder. 

• A new Search Engine Optimization reporting tool that scans your site and warns you 
about any SEO-related issues (See Help for the SEO rules). You can choose SEO options, 
display an SEO report, filter the results in the SEO report, and step forward and back 
through the list of results in the SEO report to see more detail for individual list items. 
You can choose to do this for one page or the entire site. 

 

Figure 1: SEO  

• Improvements to Publishing UI (Publish All, Publish Changed, and Publish Current File 
on on the Site menu) and fixes for "Publish Selected Files."  

 

Figure 2: Publishing Options 

• Limited customization of toolbars. While you will NOT be able to customize any of the 
current toolbars, you can create your own "Favorites" toolbar by using an Expression 
Web add-in available in the Expression Gallery - Custom toolbars add-in for Expression 

http://blogs.msdn.com/b/xweb/archive/2010/06/07/easily-create-an-add-in-for-expression-web-4-with-the-add-in-builder.aspx
http://blogs.msdn.com/b/xweb/archive/2010/06/07/easily-create-an-add-in-for-expression-web-4-with-the-add-in-builder.aspx
http://gallery.expression.microsoft.com/en-us/CustomToolbars
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Web 4. 

 

Figure 3 - Favorites Toolbar Add-in. 

• Many bugs reported by customers via Microsoft Connect have been fixed.  
• The Free version of Expression Web also has the following bug fixes: 

o Nested object tags are now supported 
o Editing with external tools is supported (e.g., edit in NotePad) and files are saved 

to the website folder rather than the temp folder 
o Also the fact that you can now see editable regions outlined with an orange 

border which did not work on EW4 even with SP2 installed. 

Which Version Should I Get? 

• Expression Studio 4 Web Professional  
• Expression Studio 4 Ultimate   
• Expression Web 4 (Free Version) 

Only the free version of the program is now available although Amazon and some other online 
distributors still offer the program for sale. 

Additional Resources 

• Expression Web 4 System Requirements 
• Expression Web 4 FAQ  (scroll down) 
• Download Expression 4 Web Free Version 
• Morten Rand-Hendricksen's First Impressions 
• Paul Laberge’s post  
• Expression Web 4 Add-in Friendly 
• Expression Web 4.0 Add-ins 
• Installing Expression Web 4 
• Easy HTML & CSS with Expression Web 4  

http://gallery.expression.microsoft.com/en-us/CustomToolbars
http://www.microsoft.com/en-us/download/details.aspx?id=36179
http://www.microsoft.com/en-us/download/details.aspx?id=36179
http://www.microsoft.com/expression/
http://www.microsoft.com/en-us/download/details.aspx?id=36179
http://www.designisphilosophy.com/microsoft-expression-web/introducing-expression-studio-4-web-professional-20100607/
http://blogs.msdn.com/b/cdndevs/archive/2010/06/07/announcing-expression-studio-4.aspx
http://expression.microsoft.com/en-us/ff714551.aspx
http://www.expression-web-tutorials.com/ew4/expression-web4-addins.html
http://www.expression-web-tutorials.com/ew4/installing-ew4.html
http://articles.sitepoint.com/article/expression-web-standards
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Expression Web 4 Books and Videos 

• Microsoft Expression Web 4 Step by Step by Chris Leeds 
• Microsoft Expression Web 4 In Depth by Jim Cheshire 
• Sams Teach Yourself Microsoft Expression Web 4 in 24 Hours by Morten Rand-Hendriksen  
• Expression Web 4 Step by Step Videos by Chris Leeds (FREE) 
• Microsoft Expression Web 4 LiveLessons (Video Training) by Morten Rand-Hendriksen 

Service Packs for Expression Web 

These are only available for the retail versions. 

Expression Web 4 Service Pack 1 (SP1) 
Expression Web 4 Service Pack 1 (SP1) was released 3/17/2011 and applies significant fixes and 
improvements to publishing, SuperPreview, file management, extensibility, and other areas of the 
programs. 

Issues that are resolved in this service pack: 

• Fixed several issues to improve product stability. 
• PHP include statements now update when included filename is changed in Web. 
• PHP pages now correctly start the development server when they are previewed. 
• Improved Insert Silverlight video. 
• Improved performance of Team Foundation Source Control with large sites. 
• Improved UI behavior of the Publishing pane. 
• User-selected character encoding for a page is now correctly recognized, resolving problems 

with extended characters. 
• Linking to a bookmark at a remote URL now works correctly. 
• The Bookmark dialog box now displays the correct hyperlink. 
• CSS IntelliSense no longer reports errors for valid values. 
• Replacing text in table cells now functions correctly. 

Improvements that are provided by this service pack: 
 
HTML 5 
 
Expression Web 4 SP1 provides support for all HTML5 tags (for pages authored using the HTML 5 
doctype) via IntelliSense within the code editor, and as block or inline entities in the Design view. There 
is no preview for <canvas> or <svg> elements, and no specific IntelliSense for SVG entities. 
 
CSS3 
 
Expression Web provides support for the draft CSS 3 specification. To enable CSS 3 error checking, you 

http://www.amazon.com/gp/product/0735639027?ie=UTF8&tag=genewebcrea-20&linkCode=as2&camp=1789&creative=9325&creativeASIN=0735639027
http://www.amazon.com/gp/product/0789747243?ie=UTF8&tag=genewebcrea-20&linkCode=as2&camp=1789&creative=9325&creativeASIN=0789747243
http://www.amazon.com/gp/product/0672333465?ie=UTF8&tag=genewebcrea-20&linkCode=as2&camp=1789&creative=9325&creativeASIN=0672333465
http://expressionwebstepbystep.com/4/video/
http://www.quepublishing.com/store/product.aspx?isbn=0789747227
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=1787
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must choose CSS 3 draft from the Schemaversion drop-down under the Authoring tab in the Page 
Editor Options dialog.  
 
The IntelliSense and error-checking in the code editor is fairly complete, and supports checking multiple 
comma-separated property values (e.g. multiple backgrounds). This support extends to the 
CSSProperties pane, as well.  
 
SP1 also provides support for selected CSS 3 properties in the New Style and Modify Style dialog boxes, 
including "border-radius" and "box-shadow." 
 
Note: There is no support in the Design view for previewing CSS 3 properties. 
 
SuperPreview Access to Pages Protected by Authentication Forms 
 
SuperPreview now supports cookie-based logon authentication. You can click on the "Page Interaction 
Mode" icon, browse to the page of interest, enter your login credentials, and view the rendered page. 
Because of the wide variety of different authentication methods used on the Internet, some sites may 
not be compatible with this feature.  
 
PHP IntelliSense 
 
IntelliSense now includes an expanded number of function groups that improve PHP coverage and 
utility. 
 
Internet Explorer 8 and Internet Explorer 9 Beta 
 
Internet Explorer 9 beta is now supported as a local browser for both SuperPreview and the Expression 
Web Snapshot feature. Internet Explorer 8 is now built into SuperPreview. If you have Internet Explorer 
9 beta installed, you can view page renderings in Internet Explorer 6, 7, 8, and 9 beta. 
 
Additional updates and features: 

• The PHP function list has hundreds of new methods, including PHP5 functions. 
• The new Open as PHP option allows Expression Web to recognize PHP files even if they don't 

have a PHP extension. Right-click on a file in the folder list, and choose Open as PHP. 
• Expression Web and SuperPreview automatically check for Chrome, Safari, and Opera and add 

them to the list of browsers you can use to preview. 
• JavaScript (.js) files now display IntelliSense for methods associated with the document object 

(for example, document.getElementById()). 
• When you click New in the File menu, the list of available file types now includes JavaScript. 
• New IntelliSense is included for extended characters—so, as soon as you type an ampersand 

(“&”), you’ll get a list of the HTML character entities that is filtered as you continue to type. 
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• The Copy Full Path command is now available when you right-click on a file in the folder list. This 
command copies the file path to the clipboard. 

• The Open Folder in Windows Explorer command is now available when you right-click on a file 
in the folder list. This command opens a Windows Explorer window. 

• Expression Web 4 now works substantially faster with sites stored in Team Foundation Server. 

Download Expression Web 4 Service Pack 1  

Expression Web 4 Service Pack 2 (SP2) 
Microsoft Expression Web 4 Service Pack 2 (SP2) contains significant fixes and improvements in support 
for jQuery, image thumbnails in the Folder List panel, a new Snippets panel, and in other areas of the 
program. 
 
Issues that are resolved in this service pack 

• Fixed several issues improving product stability. 
• Fixed items and visuals in the Insert Symbol dialog. 
• The CSS property "overflow: hidden" now behaves correctly on the design surface. 
• Improved handling of the HTML "name" attribute. 
• Added a notification error in Snapshot panel. 
• Fixed online help links in several places. 
• Fixed an issue with Copy/Paste in the Folder List panel. 
• Fixed an issue in which CSS media queries were removed by the "Reformat HTML" command. 
• Fixed several issues that affected the formatting of special characters and symbols. 
• Src and link handling now allows protocol-relative URLs. 
• Fixed an issue in which deleting a table row or column through the context menu caused 

unexpected behavior. 
• The Hyperlink dialog now properly handles links that are already URL-encoded. 
• The CSS property "pre-wrap" now behaves correctly on the design surface. 
• Fixed ALT+F1 shortcut for the Folder List panel. 
• Fixes to the JavaScript extensibility model. 

Improvements provided by this service pack 
 
jQuery support 
 
IntelliSense has been added for jQuery. In addition to the jQuery functions themselves, this provide 
IntelliSense for ids and classes in your document when creating jQuery selectors. It also includes the 
ability to continuously chain jQuery function calls and obtain IntelliSense. 
 
New Snippets Panel and improved Snippets behavior. 
 
Snippets now appear in their own panel. This panel provides all the previous functionality of the 
snippets feature, including keyboard accessibility from Code View with CTRL+ENTER. Snippets previously 

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=1787
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26699
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created by the user will be automatically migrated to the new snippet format and appear in the Snippets 
panel. 
 
In addition, the Snippets panel provides the following improvements: 

• Ability to create folders to categorize your snippets. 
• Ability to create wrap snippets—with before and after sections—that you can use to surround 

text you select in Code view. 
• Includes a large number of new sample snippets across several categories. 
• Ability to quickly search the Snippets panel to find snippets by name, description, and the code 

of the snippet itself. 

 

Figure 4 - Improved Snippets Panel 

 
Image Thumbnails in the Folder List Panel 
 
The Folder List now provides an image thumbnail preview in Windows 7 and Vista. This includes 
information such as file size, width, and height of the image for reference. Quick links, next to the image, 
CSS, and JavaScript files, copy relevant markup to the clipboard, and paste it into your code. 
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Figure 5 –Thumbnails in Folder View 

 
Interactive Snapshot Panel 
 
The Snapshot panel now provides an Interactive mode for both Internet Explorer and Firefox. This mode 
allows you to preview dynamic content and code in a browser inside Expression Web. All JavaScript and 
other interactive content will behave just as if you used the Preview in Browser command. 

 

Figure 6 - Interactive Snapshot Panel 

 
Universal comment/uncomment 
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Code view now provides context-sensitive comment and uncomment functionality. The appropriate 
type of comment will be inserted, depending on the type of code block you currently have selected in 
your document. Comment/uncomment supports HTML, CSS, PHP, and JavaScript. 
 
Workspaces 
 
Customers can now define and save multiple layouts of their application and panels. Several starter 
workspace layouts are provided. In addition you can create your own panel layouts and save them to 
custom workspaces of your choosing. 

 

Figure 7 - Workspaces Panel 

 
 
Custom Toolbars 
 
The popular Custom Toolbars Add-in has been directly built into the application, enabling you to create 
and name multiple custom toolbars and to add items of your choosing to each of them. 

 

Figure 8 - Custom Toolbars Dialog 
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Look and feel improvements to the Code View 
 
Code now uses the popular Consolas font by default. Color and syntax highlighting in Code view have 
also been improved. 

DOWNLOAD Microsoft Expression Web 4 Service Pack 2 
 
You can tell if SP2 is installed by clicking About Microsoft Expression Web from the Help menu. If 
Expression Web 4 SP2 is installed, the following version number appears: Microsoft Expression Web 4 
Version 4.0.1303.0 SP2. 

 

  

http://www.ascendercorp.com/font/consolas/
http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26699
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User Interface - Changes to the User Interface 
If you are upgrading from Expression Web 3.0 to version 4, you will notice very little change in 
the user interface. If, however, you are moving from an earlier version (1.0 or 2.0) there have 
been some major changes to the UI.  

Expression Web 3 and 4 follow the same look and feel found throughout Expression Studio. This 
consistent, uniform interface is new for Expression Web 3 and 4.  

With the release of Service Pack 1 for Expression Web 3 and in Expression Web 4, you now have 
the ability to choose between an improved black and gray color scheme which is the default, 
that better reflects the appearance of the Microsoft Expression Studio family of products or the 
Windows color scheme. 

You cannot customize the menus or toolbars in Expression Web 3.0 or 4.0. To give you an idea 
of the difference in how the various versions of Expression Web look looks, see the screenshots 
below: 

 

Figure 9 - EW 2.0 User Interface 

 

Figure 10 - Expression Web 3.0 and 4.0 
Default User Interface 

 

Figure 11 - Expression Web 3.0 and 4.0 
Windows Color Scheme User Interface 

 

Figure 12 – Left EW 3 and 4  Right EW 2.0 Program Tab 

 
Some menu items have also been removed or changed to a different location.  

Site management  

One of the biggest changes from an earlier version to Expression Web 3 and 4 is to site 
management. Expression Web provides new tools to help you publish content to your site. 
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With Expression Web 2.0 much of the site management functions were done through the 'File' 
menu which included:  

• File > New > Website 
• File > Open Site 
• File > Close Site 
• File > Publish Site 
• File > Import > Import Site Wizard 
• File > Import > Personal Web Package 
• File > Export > Personal Web Package 
• File > Recent Sites 

 

 
 

Figure 13 - Expression Web 2.0 File Menu 

In Expression Web 3.0, these functions have been moved to the 'Site' menu  

• Site > New Site 
• Site > Open Site 
• Site > Recent Sites 
• Site > Publishing 
• Site > Publishing Settings 
• Site > Export to Web Package 
• Site > Import > From Web Package 
• Site > Import > Import Site Wizard 
• Site > Manage Sites List 
• Site > Site Settings 

  

Figure 14 - Expression Web 3.0 Site Menu 

In Expression Web 4.0, some additional functions have been added to the ‘Site’ menu 

 

Figure 15: Expression Web 4.0 Site Menu 

• Site > New Site 
• Site > Open Site 
• Site > Recent Sites 
• Site > Publishing 
• Site > Publishing Settings 
• Site > Publish Current File 
• Site > Publish Changed Files 
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• Site > Publish All Files  
• Site > Delete 
• Site > Export to Web Package 
• Site > Import > From Web Package 
• Site > Import > Import Site Wizard 
• Site > Manage Sites List 

Task Panes now Panels 

'Task Panes' in the earlier versions have been renamed to 'Panels' in Expression Web 3.0 and 
4.0. You can have multiple panels open at one time and change the location and size of each 
panel to suit your needs. When you first start Expression Web 3.0 and 4.0, the 'Folder List', 'Tag 
Properties', 'Apply Styles', and 'Toolbox' panels will be docked on either side of the editing 
window. 

 

Figure 16 - Expression Web 4.0 Default Workspace 

Once you rearrange the panels in a layout that works for you, Expression Web automatically 
uses this layout the next time you start the program. I prefer mine docked on the left-hand side 
of my workspace. You can also autohide the panels. Check Help > User Guide for additional 
information on each of the 'Panels' available to you. 

Include Page Option 

The Include Page option is no longer available on the Insert menu, and you cannot add it. 
Include Page IS AVAILABLE from the 'Standard Toolbar' (Figure 17 - Standard Toolbar Include 
Page Icon) or the ‘Common Toolbar’ or you can create a code snippet.  

http://www.expression-web-tutorials.com/include-code-snippet.html
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Figure 17 - Standard Toolbar Include Page Icon 

Snapshot Panel 

The 'Snapshot' panel displays a browser rendering of an HTML, PHP, ASP, or ASPX page that is 
updated every time you save the page.  The Snapshot panel works from inside Expression Web 
AND you can move the panel and dock it wherever you like or AutoHide it. You can use the 
dropdown list to choose which browser the page will be displayed in and which screen size will 
be used. 

With the release of Service Pack 2, Interactive Mode has been added to Snapshot. SP2, puts 
Internet Explorer (current installed version) in a panel, and allows you to see and interact with 
web pages during the authoring process. Any mouse-overs, lightboxes and animations all work. 
Firefox is also available in the interactive Mode. (See Figure 6 - Interactive Snapshot Panel) 

To activate Snapshot   

• On the Panels menu > click Snapshot. The Snapshot panel appears.  
• On the View menu > click Page > click Snapshot.  

 

Figure 18 - Snapshot Panel 

SlapShot 
SlapShot is a new extension written for Expression Web 4. For those of you who already use the 
SnapShot panel (a feature that debuted in Expression Web 3), you will feel right at home with SlapShot. 

SlapShot is based on the same premise in that you can easily preview a page 
without loading a browser, however SlapShot extends the features of SnapShot 
by including full ActiveX support (Silverlight®, Flash®, and so on), as well as 
interactivity within the page (including navigation). 

For a detailed tutorial Snapshot and Snapshot Interactive Online by Tina Clarke. 

  

http://any-expression.com/expression-web/4-tutorials/snapshot.htm
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SuperPreview 

 'SuperPreview' (Figure 19 - Screenshot SuperPreview) is available from within Expression Web. 
It allows you to preview and compare pages simultaneously in multiple browsers, as well as in 
multiple versions of Internet Explorer. You can also compare browser views against a 
comprehensive mock-up ("comp") image. You can select individual elements within a page and 
see details about each selected element, helping you quickly find and fix cross-browser layout 
and positioning errors.  

Debug your pages in multiple browsers on the same machine that you use for development 
with Expression Web SuperPreview. SuperPreview supports Internet Explorer, Firefox with a 
local client, and Macintosh Safari with an online service beta. Internet Explorer 9 (beta) is also 
supported via the online service. 

Expression SuperPreview Remote Beta will continue running as a service through June 30, 2013. 

 

Figure 19 - Screenshot SuperPreview 

SuperPreview Resources 

Tina Clarke’s detailed tutorial Expression Web 3.0 SuperPreview 
SuperPreview Online Service in Expression Web 4 SP 1 by Tina Clarke 
Activating SuperPreview online service 
The SuperPreview workspace by Microsoft 
Cross-browser Development with SuperPreview from SitePoint 
Microsoft Expression Web 4 SuperPreview Online: See Your Website as Others See It 
Displaying pages in SuperPreview 
 

http://any-expression.com/expression-web/v3-tutorials/superpreview.html
http://any-expression.com/expression-web/4-tutorials/superpreview-online-service.htm
http://expression.microsoft.com/en-us/library/ff724039%28Expression.40%29.aspx
http://expression.microsoft.com/en-us/library/ff724023%28Expression.40%29.aspx
http://articles.sitepoint.com/article/browser-superpreview
http://www.quepublishing.com/articles/article.aspx?p=1606237
http://expression.microsoft.com/en-us/library/ee371310%28Expression.40%29.aspx
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Next Step: Installing Expression Web 4.0  
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Installing Expression Web 4 
The free upgrade from Expression Web 3 to Expression Web 4 is no longer available. If you 
were eligible and still have the program burned to a disk then you can install it. If not, your only 
option is the free version of the program.  

Licensing 

The retail version of Expression Web 4 can be licensed and activated on, at most, two systems, 
e.g., a laptop and a desktop. The free version of Expression Web 4 can be installed on as many 
machines as you wish and requires no activation.  

If you need to reinstall on one of those systems, e.g., because you reinstalled Windows, you 
should be able to reinstall Expression Web 4 and reactivate at that time.  

IMPORTANT NOTE: If you are having a problem with Expression Web activation or if the 
product will not accept your product key, you may have a corrupt license store. That problem 
often cannot be resolved without the assistance of Microsoft Consumer Technical Support.  
Please check out the post Forum FAQ and Guidelines - Start Here for solutions. 

Download Links: 

• Expression Web free version 

Note: Screenshots were done installing Expression Studio Ultimate on a Windows Vista 
machine. 

Installation 

NOTE: Before you can install Expression Web (either version), you will need to have .NET 
Framework 4.0 installed. You may want to go ahead and download and install it as your 
computer will need a restart after installation. If you do not install it first, then you will be 
prompted to do so BEFORE you can continue with the EW installation. 

http://social.expression.microsoft.com/Forums/en-US/web/thread/7fd16fa3-1944-4522-8848-a6a2926a253b
http://www.microsoft.com/en-us/download/details.aspx?id=36179
http://www.microsoft.com/en-us/download/details.aspx?id=36179
http://www.microsoft.com/downloads/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en
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Figure 20: Microsoft .NET Framework 4 Install message. 

Step 1: Once you have downloaded the program file, double click on the file to start the 
installation. You will receive the normal User Account Control warning box. Click Yes. You will 
see the screen shown below as the install process starts. 

 

Figure 21: Expression Studio 4 Ultimate Install Screen. 

NOTE: If your are installing a retail version of Expression Studio 4 Web Professional OR 
Expression Studio 4 Ultimate, you will be prompted at this point to enter your Product Code. 
You will NOT receive this prompt if you are installing the free version.  

 

Figure 22: Enter Product Key screen. 

Step 2: Accept the license agreement. 
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Figure 23: License agreement. 

Step 3: Choose whether you wish to join the Customer Experience Improvement Program. 

 

Figure 24: Join the Customer Experience Program. 

Step 4: Select which of the programs you wish to install. 

 

Figure 25: Which Programs to Install Screen. 
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Step 5: Once all of the program you have selected are installed, you will see the finish setup 
screen. You can either view the Release Notes of click Finish.

 

Figure 26: Installation Complete. 

Once you have installed Expression Web, you should obtain Service Pak 2. It can also be installed via 
Windows Update. 

NOTE: The free version does not require the installation of SP1 or 2. 

Activating Expression Studio 

Step 6: Launch Expression Web 4.0. Click on the 'Help' menu and choose 'Activate Product.' 
You can then check ‘About Microsoft Expression Web' from the Help menu and you should see 
that you now have a fully licensed copy. 

NOTE: The free version of Expression Web does NOT require activation. 

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26699
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Figure 27: About Expression Web 4 Product Screen. 

Important: If you took advantage of the free upgrade from version 3 to version 4, save your 
copy of version 3!  If you need to reinstall Expression Web 4, after you have reformatted your 
computer, for example, you will need to first install and license version 3, then install version 4.   

If you have not reformatted your computer but only need to reinstall the program, you should 
not have any problem, as the version 3 license will still be in the Windows license store even if 
you had previously uninstalled version 3.  

IMPORTANT NOTE:  The free upgrade is no longer available for download.  

Installation and Activation Help 
If you are having problems installing or activating Expression Web, make sure and check the 
“Forum FAQ and Guidelines - Start Here” sticky on the Microsoft Forum for some of the Known 
Issues and Resolutions. You will need to scroll down to the bold-face headings for: 

• Common Questions and Problems 
• Installation FAQs  
• More Microsoft Resources for Installation Problems 

http://social.expression.microsoft.com/Forums/en-US/web/thread/7fd16fa3-1944-4522-8848-a6a2926a253b


Expression Web 4.0 Tutorials from Install to Publish and More Page 30 
 

New Fix for Licensing and Activation Issues with Expression Web 4 
Microsoft has just released a fix for licensing and activation issues that crop up with Expression Web 4. 
Some of the symptoms of licensing and/or activation issues may include: 

• Expression Web 4 reverts to trial mode. 
• You receive a message that states that the product key is invalid. 
• The product key is not accepted during the Expression Web 4 installation process. 
• You receive a message that states that Expression Web 4 was already activated with the 

product key. 

If you are experiencing any problems such as this, the fix Microsoft has released should resolve the 
issue. For additional details and to download the fix go to: 

http://support.microsoft.com/default.aspx?scid=kb;en-US;2635101  

To download the fix, click the “View and request hotfix downloads” hyperlink at the beginning of the 
article. You will first have to accept the Terms & Conditions BEFORE being directed to the download 
page. 

This fix is only for Expression Web 4. If you are encounter a licensing or activation issue with another 
Expression Studio product, you will need to open a support case with Microsoft to get that issue 
resolved. To open a support ticket with Microsoft see Forum FAQ and Guidelines – Start Here and scroll 
down to the 3rd bold-faced item which states, in part: 

If you are having a problem with Expression Web activation or if the product will 
not accept your product key, you may have a corrupt license store. That problem 
often cannot be resolved without the assistance of Microsoft Consumer Technical 
Support. For these issues, you can open a case with us using the steps outlined 
above. There will be no charge for these cases. Using any other method to contact 
Microsoft will not get you to the right group. Please contact us using the method 
outlined above. 

If you download the patch and you receive an error that Web_en.msi could not be located, please 
download the “FullFile” version of the fix and install it on top of your existing installation. This will 
upgrade your existing installation of Expression Web 4 to SP2a which includes the fix. See the download 
link listed above.  

http://support.microsoft.com/default.aspx?scid=kb;en-US;2635101
http://social.expression.microsoft.com/Forums/en-US/web/thread/7fd16fa3-1944-4522-8848-a6a2926a253b
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Setting Up Expression Web 4.0 
Now that you have installed Expression Web 4.0, you can make some changes in the default 
setup of the program that will make Expression Web easier to work with. These changes to the 
setup can also reduce your frustration level with the code that is created and enhance your 
working experience. 

This page is a brief summary of the various settings.  Each of these is explained in greater detail 
in Tina Clarke's FREE Setting Up Expression Web 4.0 EBook which has been revised to include 
Service Packs 1 and 2. 

NOTE: If the default black color scheme is NOT to your liking and you want to change and use 
your Windows Color Scheme rather than the default, Tools > Application Options > General Tab 
> Use your current Windows color scheme. The result will depend on what color scheme you 
are using.  

View Screenshot Default Color Scheme 
View Screenshot Windows Color Scheme 

HTML <!DOCTYPE> Declaration  

The default doctype used by Expression Web 4 for new documents is: 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html 
xmlns="http://www.w3.org/1999/xhtml">  

If you are moving from FrontPage or another web editor you may not have any doctype 
declaration on your pages. Why is it important to include a doctype declaration as part of your 
page? 

The doctype you use will influence the way browsers render your page. The lack 
of a doctype (or the presence of an invalid one) can change the layout of your 
page completely, as the browser will use quirks mode instead of standards mode 
to interpret your code. As the name suggests, you can expect the render to 
include a few quirks if you take this route. ~ Sitepoint ~ 

To add or change the DocType declaration in an existing page 

With the page open in Code View, do one of the following: 

• If your page already has a DocType declaration, select the entire DocType declaration. 

http://any-expression.com/expression-web/ebooks/setting-up-expression-web-ebook.htm
http://www.expression-web-tutorials.com/ew4/images/ew4-default-color.jpg
http://www.expression-web-tutorials.com/ew4/images/ew4-windows-colors.jpg
http://articles.sitepoint.com/article/expression-web-standards
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• If there is NO DocType declaration, place your cursor at the very top of the page before all other 
code in your page.  

Do one of the following:  

• Press CTRL+ ENTER (NOTE: If you have SP2 installed the Code Snippets Panel will become 
available) 

• On the Edit menu, point to IntelliSense, and then click List Code Snippets. (Not available with 
SP2) 

• On the Code View toolbar, click List Code Snippets (Not available with SP2) 

In the list of code snippets, do one of the following:  

• Type the keyword for the code snippet, and then press ENTER or TAB to insert it.  
• Select the code snippet you want to insert, and then press ENTER or TAB to insert it.  
• Double-click the code snippet you want to insert.  

HTML 5 doctype and Intellisense 
There are 3 different doctypes in HTML 4.01, In HTML5 there is only one: <!DOCTYPE> 

If you wish to use HTML5 as your default doctype, you need to change your page editor options choose  
Tools > Page Editor Options. On the Authoring tab, set both the Document Type Declaration option and 
Secondary Schema options to HTML5.  
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Figure 28 - Page Editor Options for HTML5 schemas. 

Once you have changed the Page Editor options Authoring tab to reflect the HTML5 schemas, 
whenever you create a new web page in Expression Web, the new page contains the HTML5 
doctype which is: 

<!DOCTYPE html> 

Now, when you edit an HTML5 document in code view, Expression Web 4 now provides 
IntelliSense for HTML 5 elements, attributes and their values. 

*** IMPORTANT UPDATE *** 

The HTML5 Schema Configuration Add-In for Expression WebAdd-in is now superseded by Expression 
Web 4 SP1! Service Pack 1 adds many more features than just HTML 5 intellisense, including support for 
the CSS3 draft specification! If you've downloaded this HTML 5 Add-In the past, it's no longer needed 
and can be removed. Go to Tools > Add-ins > Select HTML 5 Schema Configuration > Click Remove 
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Figure 29 - Manage Add-ins. 

Tools > Page Editor Options > General Tab 
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Figure 30: Page Editor Options > General Tab 

I tick everything except: 

• Assign unique IDs to new tables 
• Selection margin 
• Automatically switch keyboard to language of surrounding text 
• Automatically add 'lang' attributes to international text (New to EW4) 

Spelling 

Click the button for spelling Options under Spelling and un-tick the radio button for 'Ignore 
spellings in uppercase' 

If you need to change the options for spelling to cover UK spellings, you will need to make the 
change in two places:  

Tools > Page Editor Options > General tab – Spelling:  Set Spelling language from the drop-
down AND 

Tools > Spelling Options > Custom Dictionaries > Set this to English (UK) as well from the drop-
down.  

http://www.expression-web-tips.com/setting-language-options-for-uk-spelling/
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Cut and Paste Options 

Make sure 'Show Paste Options buttons' is ticked which will display the Paste Options button 
when you paste text or elements into a page. When you click the button, a list appears with 
options for pasting the text or element.  

Code View Options 

I tick everything except: 

• Word wrap 
• Selection margin 

Two of the most important ones are that should always be ticked are: 

• Highlight Invalid HTML which will display invalid HTML in a specific color scheme (the default is 
red text on a yellow background). If you choose to change the colors, you can specify this color 
scheme in the Color Coding tab of the Page Editor Options dialog box.  

• Highlight Incompatible HTML which will display a wavy underline beneath code that isn't 
compatible with HTML standards.  

Tools > Page Editor Options > Code Formatting Tab 
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Figure 31: Page Editor Options > Code Formatting Tab 

Tick 'tag names are lowercase' and 'attribute names are lowercase' - the default doctype for 
Expression Web 4 is XHTML, which requires all code be written in lowercase. Even if you decide 
to change your doctype to HTML rather than XHTML, it is a good habit to get into and will make 
a future change easier. 

'Attribute names are alphabetized' is ticked by default. If you leave the default setting, your 
meta tags will NOT remain in the order you set BUT will be reorganized in A-Z order. I 
recommend NOT having this selection ticked.  

Tick 'indent properties on new line.' 

Tick 'Use shorthand properties when generating styles.' Use shorthand CSS attributes instead 
of longhand. As an example, with this option selected, Expression Web would define the values 
of the width, color and style of a border by setting only the border attribute in the style.  

Example Using Shorthand:  #masthead {border: 1px solid #000000;} 

With this option cleared, Expression Web would set an attribute and value for each border 
attribute.  

Example using longhand: 
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#masthead { 

border-bottom:1px solid #000000; 
border-left:1px solid #000000; 
border-right:1px solid #000000; 
border-top:1px solid #000000; } 

Both accomplish the same style BUT the shorthand code is much shorter. 

If you set the Right Margin at a high number (2000), this will keep your code from wrapping. 

Tools > Page Editor Options > CSS Tab 

 

Figure 32: Page Editor Options > CSS Tab 

If you are new to CSS, tick the 'Auto Style Application.' 

The Page properties on the <body> tag should be set to rules and everything else to classes 

• Page properties on the <body>tag  
• Font and text  
• Background  
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• Borders  
• Padding and margins  
• Sizing, positioning, and floating  
• Bullets and numbering 

Only reuse classes with the prefix style' option  

If you tend to use the formatting toolbar to add styling to your page, which is not a good habit 
to get into, you may also wish to check the 'Only reuse classes with the prefix style' option. 
Why? Your page can quickly fill up with auto-generated styles - style1, style2, style3 and so on. 
Expression Web can help with this issue by automatically reusing styles with the same 
properties where possible.  

Example: Create a short paragraph of text (one line) and apply underline to the text. The 
following will be added to your <p> tag class="auto-style1" and the associated style block would 
be added to the head section of your page: 

<style type="text/css"> .auto-style1 { text-decoration: underline; } </style>  

If you then change the text color of this paragraph to #CC3300, then EW would just update 
style1 accordingly. 

<style type="text/css"> .auto-style1 { text-decoration: underline; color: 
#CC3300; } </style>  

 If you then add a second paragraph of underlined text, style2 would be created in the head 
section and applied to the paragraph.  

.auto-style2 { text-decoration: underline; }  

If you then apply the same color #CC3300 to that paragraph, both paragraphs would be 
updated to use the same style — style1 — and style2 would be deleted. 

If you see a lot of style1, style2, etc in the head section of your page, please read What are all 
the style# in my page?  

Tools > Page Editor Options > Authoring Tab 

http://www.expression-web-tutorials.com/style1-created.html
http://www.expression-web-tutorials.com/style1-created.html
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Figure 33: : Page Editor Options > Authoring Tab 

For New Documents: 

• Tick your default file extension .htm or .html. It does not matter which one you choose, just be 
consistent. See warning below. 

• Adding a BOM on PHP pages causes problems because it will appear on the webpage disrupting 
the display. Introduced in EW 2.0 and available in EW 4.0 is the ability to turn off the addition of 
a byte order mark in UTF-8 pages by file extension. By default, only the .php extension has the 
BOM turned off.  I turn it off on all pages.  I do so by clearing the checkmark from each the file 
extensions listed.  

EW 3.0 and 4.0 .htm bug  

WARNING: If you choose to use the .htm file extension, be aware that there is a bug in 
Expression Web 3.0 and 4.0. If you use any of the generic site templates that ship with 
Expression Web or any third party Site Templates to create your website, and have selected the 
.htm file extension, you will see before your eyes the index.html page change to default.html.  
If you blink, you may miss this. This is a little known bug.  

If you have it set the default extension to .html then your homepage extension will remain 
index.html. You can, of course, rename your homepage file to whatever your host requires by 

http://www.frontpage-to-expression.com/site-templates/equal-height-site-templates.html
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right clicking on the selected link in Folder List View (Panels - Folder List or Alt + F1) and 
choosing 'Rename'.  

EW 4.0 .htm bug  

WARNING - This bug affects Expression Web 4.0 ONLY but is a more serious bug than the one 
mentioned above. 

If you download and install any third party .tem Site Template package such as those offered by 
Migrating from FrontPage to Expression Web and at the same time have you default page 
extension set to .htm, you will see the following behavior: 

1. RENAME the first file in the list of files, from whatever it is named to default.html  
2. A dialog box will appear (see Figure 35: Replace file message) asking "A file with the name 

default.htm already exists. Do you want to replace this with your file?"  
1. If you say YES, then EW 4.0 will proceed to delete the next file in the Folder List. It will 

continue to do this each time you say yes, till all that is left is the changed default.html 
which is now your homepage.  

2. If you say NO, then it will ask for each file in the list, till it has worked through them all, 
however the file renamed to default.html remains and is now your homepage.  

 

Figure 34: Replace file message 

 
Until this bug is fixed, I would strongly suggest choosing .html as the default file extension. That 
choice will affect all new files. Old files will remain untouched and you can always rename the 
file to use the .htm extension if you so choose. 

NOTE: This bug has NOT been corrected with the release of Service Pack 2. It has also NOT been 
fixed in the free version of Expression Web. 

Doctype and Secondary Schema 

The default settings are:  

• Document Type Declaration - XHTML 1.0 Transitional  
• Secondary Schema - Internet Explorer 8.0 

http://www.frontpage-to-expression.com/site-templates/
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CSS Schema 

The default setting is: 

• CSS Schema: - CSS 2.1  

Tools > Page Editor Options > Intellisense Tab 

 

Figure 35: Page Editor Options > Intellisense Tab 

Tick all the boxes provided. Intellisense works in Code View and allows you to look up and insert 
code that's compatible at the place in your code where your cursor is currently located. 

In Code View, place your cursor where you want the tag and type the opening <.  When the 
Intellisense menu pops up, scroll to the entry you want. You can press Enter or double-click to 
insert it. Intellisense is also available when you are editing an existing tag or from the Quick Tag 
bar. 

Intellisense can also be using while working with CSS. 

IntelliSense provides:  
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• Auto-insertion of end tags, end braces, and value quotes.  
• Context-sensitive shortcut menus that list and can insert code that is compatible at the current 

point in the code.  
• Context-sensitive ScreenTips that list variables, functions, or parameters that are compatible at 

the current point in the code.  
• Code hyperlinks, which enable you to click hyperlinks or references to classes, external CSS files, 

and script functions to open or go to the source of these items.  

The DocType declaration in a page determines the options that appear in the IntelliSense 
shortcut menus in the Code view of a page.  

As an example: If you are using the default doctype declaration XHTML 1.1, Expression Web will 
NOT offer the target attribute as it has been deprecated in XHTML.  

 In addition, the option you set for the CSS Schema in the Page Editor Options dialog box 
determines the level of CSS that appears in IntelliSense shortcut menus.  

There are other tabs you can explore under the Page Editor Options settings, but the ones listed 
above are the main ones. For greater detail, download Setting Up Expression Web 4 by Tina 
Clarke. 

  

http://any-expression.com/expression-web/ebooks/setting-up-expression-web-ebook.htm
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Create New Website in Expression Web 4.0 
NOTE: There are some major changes in the User Interface of Expression Web 3.0 and 4.0 
from previous versions. Many of the items to manage your site are now located on the Site 
Menu list.  

 

Figure 36 - Site Menu 

Now that you have Expression Web 4.0 installed and you have set up the program following the 
Setting Up Expression Web tutorials and Tina’s FREE EBook, you are ready to start working on 
your new web. If you have already created a website you can open it in Expression Web. There 
is no need to import the site. Be sure you have a good backup just in case.   

WARNING:  If your current website is using the Shared Borders feature of FrontPage DO NOT 
OPEN THE SITE in Expression Web 4.0 without first removing the shared borders.  WHY? 
Because Expression Web corrupts the feature and replicates the shared borders.  For more 
details see How Expression Web 4 treats Shared Borders.  

Or you can create a new website and start from scratch. NOTE: Screen shots may look different 
from what you see. I am running Expression Web 4.0 on a computer with Windows Vista 
Ultimate installed. 

Create a One Page Website 

Step 1: Start Expression Web > Site > New Site. 

http://any-expression.com/expression-web/ebooks/setting-up-expression-web-ebook.htm
http://www.rxs-enterprises.org/fp/articles/2011/11/10/06/How_Expression_Web_4_treats_shared_borders.aspx
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Figure 37 - New Site 

Step 2: In the dialog box  

1. Choose General > One Page Web Site >   
2. Under specify location of the new website, place your cursor in the box and delete from 

the right end up to the slash after MY WEB SITES\ or you can browse to the location 
where you want the new web created. Type in the name of your website — use a 
hyphen rather than an underscore. I use the actual name of my domain as the folder 
name, without the extension. Example: expression-web-tutorials. 

3. Tick the box if you want this site added to your Manage Sites Listing and specify the 
Name of your site. The default is the name you type in the location box, BUT you can 
change it to include CAPS and spaces, i.e., Expression Web Tutorials. 

4. Click OK. 

 

Figure 38 - New Site Dialog 

Step 3: The new website will be created with one page named default.html. I immediately 
rename it to index.html by right clicking on the file (from the Folder List Task Panel) > Rename.  
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Figure 39 - Rename 

 
Step 4: Use this for you new website. At the same time, I create a new folder for images. 

Either click the new folder icon,  OR Right Click > New > Folder > type images. 

 

Figure 40 - New Folder Icon 

The default doctype used in Expression Web is: 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html 
xmlns="http://www.w3.org/1999/xhtml"> 

You can change that in Tools > Page Editor Options > Authoring. 

Now that you have created your website, you can either open the default.html, or index.html if 
you renamed it, and begin creating a page that will serve as the template for your site. 

If you would like a starting point for designing your new website, please feel free to download 
and use one of these FREE CSS based layout templates available from Genealogy Web Creations 
or import one of the Personal Web Packages from Expression Web Tutorials & Templates.  

http://www.genealogy-web-creations.com/css-layouts/
http://www.expression-web-tutorials.com/ew-templates.html
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You might also consider downloading and installing one or all of the FREE Expression Web Site 
Template sets. There are four different layout sets available as well as some equal height 
column templates.  

Cheryl Wise also has a selection of templates you may choose to use. 

I would encourage you to start from scratch if you are starting out with the program. 

  

http://www.frontpage-to-expression.com/site-templates/
http://www.frontpage-to-expression.com/site-templates/
http://by-expression.com/page/Templates
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Create a Blank Web Page 
Now that you have actually created your website, you will need to create your Home Page. If 
you created a one page website, your Home Page was created at that time. If you created a 
blank website, you will need to create a Home Page for the site. 

Expression Web 4.0 can create various types of pages, BUT in this tutorial we will create an 
HTML page and its corresponding style sheet. Types of pages that can be created include: 

• HTML 
• ASPX 
• ASP 
• PHP 
• CSS 
• Master Page 
• Dynamic Web Template 
• Javascript 
• XML 
• Text File 

Create a Blank Web Page 

Step 1: There are a number of ways for you to create your new page: 

• Ctrl + N 
• File > New > HTML  
• Click File > New > Page > General > HTML. 
• Click the New Document dropdown from the Common or Standard Toolbar > select 

HTML. 

If you click the Code Tab and view the page source, you should see something like what is 
below.  

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">  
<html xmlns="http://www.w3.org/1999/xhtml">  
<head>  
<meta content="text/html; charset=utf-8" http-equiv="Content-Type" /> 
<title>Untitled 1</title>  
</head>  
<body>  
</body>  
</html>  
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Step 2: Depending on what you chose as your default extension, when you set up EW 4.0, your 
newly created page has the file name Untitled_1.html or Untitled_1.htm.  You will need to save 
the page.  

Saving the Page 

Step 3: There are a number of ways to save your pages: 

• Ctrl + S 
• Right Click the page tab. > Select Save. 
• Click File > Save. 
• Click the Save Icon on the Common or Standard Toolbar. 

In the dialog box that opens, 'file name' will be highlighted. > Type 'index,' > press the Enter key 
OR click 'Save.'  It is not necessary to add the file extension .htm or .html. Expression Web will 
do it for you. Your page has been saved, and you are ready to add the external style sheet.  

Create an External Style Sheet (CSS) 

Step 4: There are a number of ways to create your new style sheet. 

• File > New > CSS  
• Click File > New > Page > General > CSS. 
• Click the New Document dropdown from the Common or Standard Toolbar. > Select 

CSS. 

Step 5: Save the page as you did, following the choices in Step 3. Type a name for the style 
sheet. Expression Web will add the file extension for you.  

Attach the External Style Sheet to the Page 

Step 6: As with many things you do in Expression Web, there is more than one way to 
accomplish a task. To attach the external style sheet to the page: 

• With the webpage open in Design view, drag the .css file from either the Folder List 
panel or the Site View onto the page. 
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• In the Manage Styles Panel  or the Apply Styles Panel, click on 'Attach Style Sheet.'  

 

Figure 41 – Manage Styles > Attach Style Sheet 

o Browse to your style sheet in the popup box. 
o Attach To: Check 'Current page.' 
o Attach As:  Check 'Link.' 
o Click OK.   

 

Figure 42 - Attach Style Sheet 

If you click the Code Tab and view the page source, you should see a line of code has been 
added to your page with the name of your style sheet.  

<link href="sample.css"  rel="stylesheet" type="text/css" /> 

Summary 

You have now created your Home Page and the external style sheet and attached the style 
sheet to your page. The next step is to create the layout for your page.  

You could use one of the premade templates that come with Expression Web or you could 
choose to download and use one of these FREE CSS-based layout templates available from 
Genealogy Web Creations or import one of the Personal Web Packages from Expression Web 
Tutorials and Templates  OR you can create a basic layout from scratch as the next tutorial will 
guide you through. 

Expression Web supports Dynamic Web Templates as a way to maintain a consistent look to 
your site. The page we are creating will be the basis for a DWT for your site. Tina Clarke offers 
free the Expression Web DWT EBook. This is an excellent resource, so be sure and take 
advantage of this free download.  

http://www.genealogy-web-creations.com/css-layouts/
http://www.expression-web-tutorials.com/ew-templates.html
http://www.expression-web-tutorials.com/ew-templates.html
http://any-expression.com/expression-web/ebooks/expression-web-dwt-ebook.htm
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Create a Webpage Layout in Expression Web 
Before you proceed with creating your webpage layout, you should have spent some time 
actually thinking about the content and the design you want to use to present that content. 

The content, after all, is what is going to draw viewers to your site. You need to decide on the 
best way to present that content so your viewers find your site and then stay to check it out.  

While you can certainly design your layout on the computer, it might be easier to just use a 
paper and pencil and draw out a rough layout of how to best present you content. 

Your layout will probably include a masthead or banner at the top, perhaps a top navigation 
menu, a content area that may include multiple columns, and footer at the bottom of the page.  

 In the past, you may have used tables to achieve this look.  Tables created an assortment of 
boxes that were used to create rows and columns. Now web designers use <div>s to form the 
boxes and CSS to place those boxes on the page. 

For this tutorial, we will be using  <div></div> tags to create the various boxes and style rules to 
place those boxes as a two column layout with masthead, top navigation bar, left sidebar, main 
content area, and footer. Each of the boxes or divs will hold the content for your page. 

What is a <div> tag? 

The <div> tag defines a division or section in a page and makes it easy to manage, style, and 
manipulate those divisions or sections. Browsers usually place a line break before and after the 
div element.  Use the <div> tag to group block-elements to format them with styles.  

 

Figure 43 - Layout example 
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The layout shown in Figure 44 shows the use of div tags.  Each div tag <div></div> creates a 
box.  Using various style rules, the boxes will be positioned to create the layout used in this 
tutorial. Once you learn the basics of working with div’s you can create one, two, or three 
columned layouts. Read more on the HTML <div> tag.  What are block-level elements? 

Create the Layout 

I would recommend working in 'Split View' rather than ‘Code View’ or 'Design View' so that 
you see the results of actions you take. Before we start, make sure your 'Toolbox panel' is 
available.  Click Panels > Toolbox. The default location is on the right-hand side of your editing 
window. You can move it wherever you like. 

 

Figure 44 - Expression Web 4.0 Workspace 

As we create the layout for our page, we will also be adding the style rules to our external style 
sheet. NOTE: When you select 'Preview in Browser,' the last browser you used will be what you 
see the preview with. You should view your pages as you develop them in BOTH Internet 
Explorer and Firefox and at more than one resolution. Not everyone is going to view you page 
with their browser open fullscreen or have the latest and greatest in monitors.  

Expression Web 4 offers two additional ways to preview your pages — 'SuperPreview' or the 
'Snapshot' panel.  To use the 'Snapshot' panel, click Panels > Snapshot. To view your pages with 
'SuperPreview,' select File > Display in SuperPreview OR Press Shift + F12. 

If it is not already open, open the page you created earlier in Expression Web. File > Open OR 
Press Ctrl + O. 

http://www.expression-web-tutorials.com/div-containers.html
http://webdesign.about.com/od/htmltags/g/bldefblocklevel.htm
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Style the <body> tag 

The body element defines the document’s body. To style the <body> tag, create a new style. 
From the 'Manage Styles' or 'Apply Styles' panel click 'New Style.' In the New Style dialog box, 
type or select the following: 

1. Selector: Choose body from the dropdown list. 
2. Define in: select ‘Existing style sheet’ from the dropdown. Select the style sheet. 
3. Font: Set the font-family and color. 
4. Background: Set your page background color. You may also choose to use a seamless 

background as the page background. 
5. Box: Set the margins and padding to 0px, which remove the default margins web browsers apply 

to a web page.  
6. Click OK. Save your page and view in your browser. 
7. At the same time, copy and paste the following to your style sheet: body img { border: 0px; text-

decoration: none; }, which will keep any images that are hyperlinks from having the ugly blue 
border. 

You can also use the ‘CSS Properties’ task panel for creating styles.  

Add the Container 

The first <div> we will add will be for the container that will "hold" all of the other <div>’s or 
elements of our page. Style rules will be added as we add the <div> tags. 

Step 1: With your page open in 'Split View,' drag the <div> from the 'Toolbox' panel and drop it 
on your open page. You will see that <div></div> has been added to your page.  

Step 2: Using the 'Quick Tag Selector,' click <div>. From the 'Manage Styles' or 'Apply Styles' 
panel click 'New Style.' In the New Style dialog box, type or select the following:  

 

Figure 45 - Screenshot Quick Tag Selector 
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Figure 46 - Screenshot New Style Panel 

1. Selector: #container (the hash mark # is an ID selector). NOTE: You can NOT select container 
from the dropdown list. You will need to actually type in #container in the selector box. 

2. Define in: select Existing style sheet from the dropdown. 
3. Check: Apply new style to document selection. 
4. URL: Browse to your style sheet that you created and attached in the previous tutorial. 
5. Background: Set the background color #FFFFFF (white.) NOTE: Using a light color for the 

container background will allow your text to be more easily read. 
6. Click the Position Category in the Style Builder.  Set it to 80% for the width. Do NOT specify a 

height so that the container can expand as you enter content. 
7. Click on the Box Category.  Set the right and left margins to 'auto,' and top and bottom to 

10px.  Set the padding to 10px. NOTE: setting the left and right margins to auto, will center the 
container on the page. 

8. Click OK. 

Your style sheet now contains the following: 

#container { width: 80%; padding: 10px; margin: 10px auto 10px auto; 
background-color: #FFFFFF; }  

and your html code contains 

<div id="container"> </div>. 

NOTE: Setting the width to a percentage, will allow the container to fill 80% of the viewer’s browser 
window NO MATTER what the size of the window is. That means if your viewer has a 15 inch laptop 
screen, the container will fill 80% of the available real estate. By the same token, if your viewer has a 
snazzy new 24 or 27 inch monitor, the container will fill 80% of the allowable screen space. You may 
choose to specify a maximum width for the container. More on CSS max-width Property. 

http://www.w3schools.com/cssref/pr_dim_max-width.asp
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Add the masthead and style rules 

1. Click and drag a <div> from the Toolbox onto the page, making sure it is INSIDE the container 
<div>. NOTE: If you have a hard time doing this, place your cursor between the opening and 
closing div tags and then drag the new div into position.  

2. Click 'New Style.' Check: Apply new style to document selection. 
3. Selector: #masthead NOTE: You can NOT select masthead from the dropdown list. You will need 

to actually type in #masthead in the selector box. 
4. Click the Position Category: set the height to 170px.  Do not set a width.  This will allow the 

header to extend across the entire width of the container. 
5. Click on the Background Category and set a background color and image if you choose to use 

one.  
6. Click OK. Save your page and view in your browser. 

Your style sheet now contains the following: 

#masthead { background-color: #54B431; background-image: url ('clover-
bg.jpg'); background-repeat: no-repeat; background-position: right center; 
height: 170px; }  

and your html code contains 

<div id="container">  
<div id="masthead"> </div>  
</div> 

Add the Top Navigation and style rules 

1. Click and drag a <div> from the Toolbox onto the page making sure it is INSIDE the container 
<div> and BELOW the masthead <div>.  

2. Click 'New Style.' Check Apply new style to document selection. 
3. Selector: #top-nav NOTE: You can NOT select top-nav from the dropdown list. You will need to 

actually type in #top-nav in the selector box. 
4. Position: set the height to 50px.  Do not set a width.  This will allow the menu to extend across 

the entire width of the container. NOTE: Additional style rules will be added later. 
5. Border: Set the top and bottom borders. 
6. Background: Set the background color. 
7. Click OK. Save your page and view in your browser. 
8. Menus are best suited to unordered lists. Additional style rules will need to be set for your top 

navigation.  

Your style sheet now contains the following: 

#top-nav { height: 50px; border-top: solid medium #006600; border-bottom: 
solid medium #006600; background-color: #FFFFFF; }  

and your html code contains 
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<div id="container">  
<div id="masthead"> </div>  
<div id="top-nav"> </div> 
</div>  

 

Figure 47 - Screenshot of Layout 

Add and style the Columns 

Our sample page will consist of two columns — one on the left for additional navigation or 
messages and the main column for content. We will float the one column to the left and place 
the main content area by applying a left margin. 

Step 1: Insert the left column 

1. Click and drag a <div> from the Toolbox onto the page making sure it is INSIDE the container 
<div> and BELOW the top-nav <div>.  

2. Click 'New Style.' Check: Apply new style to document selection. 
3. Selector: #left-nav NOTE: You can NOT select left-nav from the dropdown list. You will need to 

actually type in #left-nav in the selector box. 
4. Position:  set the width to 180px.  Again, do not set a height so the column will expand as you 

add content. 
5. Layout:  float: left.  
6. Background: Add a background color or a graphic. If you do not specify the background color, 

the container will be seen.  
7. Border: Add a border to this container if you wish. 
8. Box: Set the top margin at 20px and the bottom margin at 10px. Set the left and right margins as 

0px. This will push the top menu down from the border of the top navigation.  
9. Click OK.  Save your page and view in your browser. 
10. Menus are best suited to unordered lists. Additional style rules will need to be set for your left 

navigation.  

Your style sheet now contains the following: 

#left-nav { margin: 20px 0px 10px 0px; width: 180px; float: left; border: 
thin dashed #006600; }  

and your html code contains 

<div id="container">  
<div id="masthead"> </div>  
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<div id="top-nav"> </div> 
 <div id="left-nav"> </div>  
</div>  

Step 2: Insert the Right or Main Content Column 

1. Click and drag a <div> from the Toolbox onto the page making sure it is INSIDE the container 
<div> and BELOW the left-nav <div>.  

2. Click 'New Style.' Check Apply new style to document selection. 
3. Selector: #main-content NOTE: You can NOT select main-content from the dropdown list. You 

will need to actually type in #main-content in the selector box. 
4. Background: Add a background color or a graphic. If you do not specify the background color, 

the color will be the same as specified in the container.  
5. Border: Add a border to this container if you wish. 
6. Box: Set the top margin at 20px and the left margin at 200px, right margin to 10px, and bottom 

margin at 10px. This will push the main content down from the border of the top navigation and 
to the right of the left navigation <div>. 

7. Click OK.  Save your page and view in your browser. 

Your style sheet now contains the following: 

#main-content { margin: 20px 10px 10px 200px; background-color: #CCFFCC; }  

 

Figure 48 - Screenshot of Layout after content added 

and your html code contains 

<div id="container">  
<div id="masthead"> </div>  
<div id="top-nav"> </div> 
 <div id="left-nav"> </div>  
<div id="main-content"> </div> 
</div>  

Add and style the Footer 

1. Click and drag a <div> from the Toolbox onto the page making sure it is INSIDE the container 
<div> and BELOW BOTH column <div>'s.  

2. Click 'New Style.' Check: Apply new style to document selection. 
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3.  Selector: #footer NOTE: You can NOT select footer from the dropdown list. You will need to 
actually type in #footer in the selector box. 

4. Border: Add a top border to this container if you wish. 
5. Layout:  clear: both — this will clear the float that was used to position the column and push the 

footer below BOTH of the columns. 
6. Block: text-align: center 
7. Box: Add padding of 10px to the top and bottom. 
8. I also add the following style rule to the footer: id #footer p { margin-top: 0px; margin-bottom: 

0px;}. This allows for the use of the <p> tag in entering the information for your footer but 
removes the top and bottom margins of the paragraphs.  

9. Click OK. Save the page and view in your browser. 

Your style sheet now contains the following: 

#footer { border-top: 2px solid #006600; clear: both; padding: 10px 0px; 
text-align: center; }  
#footer p { margin-top: 0px; margin-bottom: 0px; }  

and your html code contains 

<div id="container">  
<div id="masthead"> </div>  
<div id="top-nav"> </div>  
<div id="left-nav"> </div>  
<div id="main-content"> </div>  
<div id="footer"> </div>  
</div>  

 

Figure 49 - Screenshot of basic layout with <div>'s identified 

Adding Meta Tags 

Your page currently contains these meta tags in the head section: 

<meta content="text/html; charset=utf-8" http-equiv="Content-Type" /> 
<title>Sample Site</title>  

You will need to add additional meta tags to the head section of your page.  
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<meta name="keywords" content=" " />  
<meta name="description" content=" " />  
<meta content="en-us" http-equiv="Content-Language" />  
<meta content="General" name="rating" />  
<meta content="Copyright © 2008-2012, You Name or Business All Rights 
Reserved" name="copyright" />  

Right click in Design View on your page > Page Properties.  

• General Tab 
o Title: Type the title for your page. 
o Page description: Type a brief description of what your page is about. 
o Keywords: Type the keywords for your page separated by commas. 

• Custom Tab (Can be used to add meta tags) 
o Click Add >  
o Name: Type copyright. 
o Value: Type Copyright © 2008-2012, You Name or Business All Rights Reserved. 
o Click OK. 

OR you can copy and paste the tags into your document. Read more on Basic Meta Tags 

Summary 

You have now completed the basic layout of your page. Additional style rules will need to be 
added for your menus, your heading tags, and floats for your images.  You can test how your 
page layout will look by adding some filler content. Some of the style rules will need to be 
modified. E.g., adding padding to the main content area and the left navigation container.  

NEXT: Adding Navigation to the Layout. This will be done in two parts. We will add a horizontal 
top menu, then a left-side navigation menu. 

  

http://www.htmlbasictutor.ca/basic-meta-tags.htm
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Adding Horizontal Top Navigation to Webpage 
Layout 
Now that you have created a basic layout for your webpage, it is time to add some navigation 
to it. First, I will show you how to add a horizontal menu for your top navigation. In a separate 
tutorial we will add a vertical menu on the left. 

Add and style the top menu 

As you develop your menu, make sure you preview it in both Internet Explorer and Firefox. You 
will also need to check it at various resolutions to make sure you do not add too many links to 
the menu. You might try viewing it using the new 'SuperPreview' feature. 

Create the menu list 
Create a simple bulleted list for your top menu. Remember you are going to be limited on the number of 
items to include so that you menu will not "break" when resized. In 'Design' or 'Code' view, in your 
webpage, place your cursor where you want to create a list, and then do one of the following: 

• On the 'Common' toolbar, click Bullets , or on the 'Formatting' toolbar, click the Style box, 
and select Unordered List. 

• Drag the page you want to include as a menu item from the 'Folder List' panel to the first bullet.  
Hit 'Enter' to add a new list item. Using this method will create your hyperlinks as you go along. 
If you have no pages as part of your website but would like to create the menu items and pages 
as you go, you can follow Creating a New Page from Hyperlink Properties. 

• OR for each item or line of text that you want in the list, type the text, and then press ENTER to 
add a bullet to the list. If you use this method, you will need to create the hyperlinks to the 
menu items. 

To create or modify a hyperlink  

• In your webpage, in 'Design' view or 'Code' view, do one of the following:  
• Select the item that you want to use as the hyperlink >. Press Ctrl + K OR right click and select 

hyperlink. 
• OR In either the 'Common' or the 'Standard' toolbar, click Insert Hyperlink. 
• In the 'Insert' or 'Edit' Hyperlink dialog box, do the following: 
• Text to display: Type the text you want to display as the menu item. 

http://www.expression-web-tutorials.com/page-from-hyperlink.html
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• Existing File or Webpage: In the Address box, browse to the file you want to link to OR Copy and 
Paste the URL of the webpage you wish to link to.  

 

Figure 50 - Edit Hyperlink Dialog Box 

• Click 'Screen Tip,'  Type a brief description of the link. For SEO purposes, use the title of the 
page. Warning: Expression Web 4.0 has a bug that causes EW to lose focus when adding the 
Screen Tip via the hyperlinks dialog box. As soon as you type the text you want and click OK, EW 
will switch to the last open window. You will need to go back to Expression Web in order to 
complete the process. NOTE: This bug appears to have been fixed with the release of SP1 and 
SP2.  

 

Figure 51 - Set Hyperlink Screen Tip 

• Continue this procedure until you have added all of your top menu links.  

If you view your source code, it should look something like the following: 

<ul>  
<li><a title="Home - Site Name." href="index-two.html">Home</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
</ul>  

Of course, each menu item would hyperlink to its own page NOT the index.html page. This is 
just an example. 
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Adding styles to the menu 

• Open your index.html page in 'Design' view. 
• From the 'Manage Styles' panel > right click #top-nav > Modify Style. 

o Select the ‘Position’ Category and REMOVE 50 from height. 
o Select the 'Border' Category and change the width to thin. 
o Select the 'Box' Category and uncheck padding: Same for all > top: 10px bottom: 10px. 

• From the 'Manage Styles' or 'Apply Styles' panel click 'New Style'. In the New Style dialog box, 
type or select the following:  

o Selector: #top-nav ul NOTE: You can NOT select top-nav ul from the dropdown list. You 
will need to actually type in # top-nav ul in the selector box. 

o Define in: select Existing style sheet from the dropdown. Select the style sheet. 
o Block: text-align: center 
o List: list-style-type: none 
o Box: margin: 0px; padding: 0px 

• From the 'Manage Styles' or 'Apply Styles' Panel click 'New Style.' In the New Style dialog box, 
type or select the following:  

o Selector: #top-nav ul li NOTE: You can NOT select top-nav ul li from the dropdown list. 
You will need to actually type in # top-nav ul li in the selector box. 

o Define in: select Existing style sheet from the dropdown. Select the style sheet. 
o Layout: display: inline 

• From the 'Manage Styles' or 'Apply Styles' panel click 'New Style'. In the New Style dialog box, 
type or select the following:  

o Selector: #top-nav ul li a NOTE: You can NOT select top-nav ul li afrom the dropdown 
list. You will need to actually type in # top-nav ul li a in the selector box. 

o Define in: select Existing style sheet from the dropdown. Select the style sheet. 
o Font: color: #ffffff 
o Background: background-color: #006600 
o Box: untick padding:  Same for all > top and bottom .2em > right and left 1em 

• From the 'Manage Styles' or 'Apply Styles' Panel click 'New Style'. In the New Style dialog box, 
type or select the following:  

o Selector: #top-nav ul li a:hover NOTE: You can NOT select top-nav ul li a:hover from the 
dropdown list. You will need to actually type in # top-nav ul li a:hover in the selector 
box. 

o Define in: select Existing style sheet from the dropdown. Select the style sheet.  
o Font: color: #000000 
o Background: background-color: #CCFFCC 
o Border: border: 1px #99BF99 solid; 
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• Save your page and Preview in Browser.  

 

Figure 52 - Page Previewed in Browser 

Converting Your Menus to Include Pages 

You may wish to use different menus for different sections of your site. Rather than have the menu as 
part of your DWT, you can create an include page or pages that can be inserted in the menu region. As 
an example, my main site Expression Web Tutorials & Templates uses one menu for the main pages and 
a separate menu for the tutorials section. If I need to make a change to the menu, I edit the include page 
which will then update each page the include is part of. You can use more than one include on a page 
and includes can be nested. 

When the Design Time include is added to your final page, only the content between the <body> and 
</body> tags is included. Any styles you create as part of the include page must be part of the external 
style sheet or they will not be applied. 

You can read more about Expression Web and Design Time Includes 

Creating the include page 
It is a good idea to save all your include files in a single folder and to give them a name which makes 
their function obvious.   

Create a new folder for the includes. Click 'Site View' tab, > Click 'New Folder' icon. > Type _includes 
as the name of the folder. 

• Click the 'New Document' icon. Save the page with the name top-menu.html in the _includes 
folder.  

• Copy and Paste the menu list from your index.html page into the new top-menu.html page. 
Delete the menu list from your index.html page. 

• Place your cursor where you wish the include file to appear. Click the include page icon on the 
standard toolbar (pictured below) OR use the Code Snippet to insert the include page. 

o Using Code Snippets to Insert Include Pages 

http://www.expression-web-tutorials.com/soccer/default.html
http://www.expression-web-tutorials.com/expression-web-includes.html
http://www.expression-web-tutorials.com/include-code-snippet.html
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o Use the 'Standard Toolbar' to insert your include page 

 

Figure 53 - Standard Toolbar 

• In the ‘Include Page Properties’ dialog box, browse to the location of your include page > Click 
OK. 

 

Figure 54 - Include Page Properties dialog box 

• The include page will be inserted into you page and you will see the following in Code View. 
<div id="top-nav"><!--webbot bot="Include" u-include="_includes/top-
menu.html" tag="BODY" --></div> 

• Preview your page in the browser and you will see your menu has been inserted within the 
page. 

If you need more detailed instructions, you can follow the tutorial Expression Web and Design Time 
Includes. 

 

Navigation Resources 

• Website Navigation - Website Navigation Structure 
• Navigation Menu - Creating A Navigation Menu 
• Website Navigation   

Whatever your final choice of navigation is, it should be a consistent navigation scheme from 
page to page throughout your site. This helps the website visitor learn your website navigation 
system.  

CSS Menu Resources 

• CSS Library Horizontal CSS Menus 
• CSS Library Vertical CSS Menus 
• CSS Play Menus 

http://www.expression-web-tutorials.com/expression-web-includes.html
http://www.expression-web-tutorials.com/expression-web-includes.html
http://www.genealogy-web-creations.com/creating-site-navigation.htm
http://www.genealogy-web-creations.com/creating-navigation-menu.html
http://www.webpagemistakes.ca/website-navigation/
http://www.dynamicdrive.com/style/
http://www.dynamicdrive.com/style/
http://www.cssplay.co.uk/menus/
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• CSS MenuMaker 
• CSS Express Drop-Down Menus - by the folks at ProjectSeven. This is my absolute favorite for a 

CSS dropdown menu. 

You will also need to make sure that whichever menu system you use, that it renders in all 
browsers.  

  

http://www.cssmenumaker.com/horizontal_css_menu.php
http://www.projectseven.com/tutorials/navigation/auto_hide/
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Adding Vertical Navigation to Webpage Layout 
Now that you have created a basic layout for your webpage, it is time to add some navigation 
to it. In the previous tutorial I showed you how to add a top navigation menu. This time we’ll 
work on a vertical menu. 

Add and style the left side menu 

As you develop your menu, make sure you preview it in both Internet Explorer and Firefox. You 
will also need to check it at various resolutions to make sure it continues to work as you expect 
it to. Or you can use the new 'SuperPreview' — Shift + F12.This menu is based on the Urban 
Grey Side Menu from Dynamic Drive.  

Create the menu list 
Create a simple bulleted list for your left-side menu. The list can be separated into sections by adding a 
<p></p> tag before starting each list.  In 'Design' or 'Code' view, in your webpage, place your cursor 
where you want to create a list (between the <div id="left-nav"></div> tags, and then do one of the 
following: 

• Type a Section heading like Site Navigation BEFORE you start your list. 

• On the 'Common' toolbar, click Bullets , or on the 'Formatting' toolbar, click the Style box, 
and select Unordered List. 

• Drag the page you want to include as a menu item from the 'Folder List' panel to the first bullet. 
Hit 'Enter' to add a new list item. Using this method will create your hyperlinks as you go along. 
If you have no pages as part of your website but would like to create the menu items and pages 
as you go, you can follow Creating a New Page from Hyperlink Properties. 

• OR for each item or line of text that you want in the list, type the text, and then press ENTER to 
add a bullet to the list. If you use this method, you will need to create the hyperlinks to the 
menu items. 

To create or modify a hyperlink 
In your webpage, in 'Design' view or 'Code' view, do one of the following:   

• Select the item that you want to use as the hyperlink. > Press Ctrl + K OR right click and select 
hyperlink. 

• OR In either the 'Common' or the 'Standard' toolbar, click Insert Hyperlink 
• In the 'Insert' or 'Edit' Hyperlink dialog box, do the following: 

http://www.dynamicdrive.com/style/csslibrary/item/urban_grey_side_menu/
http://www.dynamicdrive.com/style/csslibrary/item/urban_grey_side_menu/
http://www.expression-web-tutorials.com/page-from-hyperlink.html
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o Text to display: Type the text you want to display as the menu item. 
o Existing File or Web Page: In the Address box, browse to the file you want to link to OR 

Copy and Paste the URL of the webpage you wish to link to. 

 

Figure 55 - Edit Hyperlink Dialog Box 

o Click 'Screen Tip.'  Type a brief description of the link. For SEO purposes, use the title of 
the page. Warning: Expression Web 4.0 has a bug that causes EW to lose focus when 
adding the Screen Tip via the hyperlinks dialog box. As soon as you type the text you 
want and click OK, EW will switch to the last open window. You will need to go back to 
Expression Web in order to complete the process. 

 

Figure 56 - Set Hyperlink Screen Tip 

• Continue this procedure until you have added all of your top menu links.  

If you view your source code, it should look something like the following: 

<p>Site Navigation</p>  
<ul>  
<li><a title="Home - Site Name." href="index-two.html">Home</a></li> 
 <li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
<li><a title="Menu Item." href="index.html">Menu Item</a></li>  
</ul>  

Of course, the each menu item would hyperlink to its own page NOT the index.html page. This 
is just an example.  
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Adding styles to the menu 

• Open your index.html page in 'Design' view. 
• From the 'Manage Styles' panel, right click #left-nav > Modify Style. 

o Select the 'Box' Category, > Make sure padding:  Same for all is ticked > 5px. 
o Select the 'Font' Category: font-size: > 0.9em. 

• From the 'Manage Styles' or 'Apply Styles' panel, click 'New Style.' In the New Style dialog box, 
type or select the following:  

o Selector: #left-nav ul NOTE: You will need to TYPE rather than select #left-nav ul 
o Define in: select Existing style sheet from the dropdown. Select the style sheet. 
o List: list-style-type: none 
o Box: margin: 0px; padding: 0px 

• From the 'Manage Styles' or 'Apply Styles' Panel click 'New Style'. In the New Style dialog box, 
type or select the following:  

o Selector: #left-nav ul li  : You will need to TYPE rather than select #left-nav ul li 
o Define in: select Existing style sheet from the dropdown. Select the style sheet. 
o Box: untick padding:  Same for all > bottom .2px 

• From the 'Manage Styles' or 'Apply Styles' panel click 'New Style.' In the New Style dialog box, 
type or select the following:  

o Selector: #left-nav ul li a : NOTE: You will need to TYPE rather than select #left-nav ul li a 
o Define in: select Existing style sheet from the dropdown. Select the style sheet. 
o Font: color: #ffffff text decoration: none 
o Display: block 
o Background: background-color: #006600 
o Box: untick padding:  Same for all > top 5px right 0px bottom 5px left 8px. 

• From the 'Manage Styles' or 'Apply Styles' panel click 'New Style'. In the New Style dialog box, 
type or select the following:  

o Define in: select Existing style sheet from the dropdown. Select the style sheet. 
o Selector: #left-nav ul li a:visited NOTE: You will need to TYPE rather than select #left-nav 

ul li a:visited 
o Font: color:  #FFFF66 

• From the 'Manage Styles' or 'Apply Styles' panel click 'New Style.' In the New Style dialog box, 
type or select the following:  

o Define in: select Existing style sheet from the dropdown. Select the style sheet.  
o Selector: #left-nav ul li a:hover NOTE: You will need to TYPE rather than select #left-nav 

ul li a:hover 
o Font: color:  #000000   
o Background: background-color: #006600 

• From the 'Manage Styles' or 'Apply Styles' panel click 'New Style.' In the New Style dialog box, 
type or select the following:  

o Define in: select Existing style sheet from the dropdown. Select the style sheet. 
o Selector: Type #left-nav .headerbar  
o Font: color: #000000  font-size: 1em >   text-transform: > uppercase 
o Layout: display: block 
o Background: background-color:  > #CCFFCC 
o Padding: untick padding:  Same for all > top and bottom 4px right and left 2px. 
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• Save your page and Preview in Browser or use 'SuperPreview.' 

 

Figure 57 - Page Previewed in Browser 

Converting Your Menus to Include Pages 

If you wish to convert your vertical menu to a Design Time Include please follow the previous 
instructions (see Converting Your Menus to Include Pages) 

Navigation Resources 

• Website Navigation - Website Navigation Structure 
• Navigation Menu - Creating A Navigation Menu 
• Website Navigation   

Whatever your final choice of navigation is, it should be a consistent navigation scheme from 
page to page throughout your site. This helps the website visitor learn your website navigation 
system.  

CSS Menu Resources 

• CSS Library Horizontal CSS Menus 
• CSS Library Vertical CSS Menus 
• CSS Play Menus 
• CSS MenuMaker 
• CSS Express Drop-Down Menus - by the folks at ProjectSeven. This is my absolute favorite for a 

CSS dropdown menu. 

You will also need to make sure that whichever menu system you use, that it renders in all 
browsers.  

 

  

http://www.genealogy-web-creations.com/creating-site-navigation.htm
http://www.genealogy-web-creations.com/creating-navigation-menu.html
http://www.webpagemistakes.ca/website-navigation/
http://www.dynamicdrive.com/style/
http://www.dynamicdrive.com/style/
http://www.cssplay.co.uk/menus/
http://www.cssmenumaker.com/vertical_css_menu.php
http://www.projectseven.com/tutorials/navigation/auto_hide/
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Validating Your Pages 
Before you can save the page you have created as a Dynamic Web Template or DWT for short, you 
should make sure that both your HTML code and your CSS code validates. To understand WHY it is 
important to validate your code read Code Validation - Clean Code by Susan Emerson.  Expression Web 
has some tools within the program that will help you with validating your page.  

Compatibility Checker on Status Bar 
Much of this information will apply to Expression Web 3.0 as well as 4.0. 

As you continue to build your site and work on your pages, you should get in the habit of validating the 
page BEFORE you publish it. Expression Web has various tools to help you with this. Two very helpful 
options that you should have already set are located under Tools > Page Editor Options > General tab. 
They are: 

1. Highlight Invalid HTML which will display invalid HTML in a specific color scheme (the default is 
red text on a yellow background). If you choose to change the colors, you can specify this color 
scheme in the Color Coding tab of the Page Editor Options dialog box.  

2. Highlight Incompatible HTML which will display a wavy underline beneath code that isn't 
compatible with HTML standards.  

Status Bar 
The Status Bar is located on the lower right hand corner of your workspace and displays among other 
things information about the file you are editing, such as file size, HTML schema, and CSS schema.  

 

Figure 58: Status Bar From L to R, the symbols: Incompatible HTML   - Invalid HTML - HTML schema - File Size - Visual Aids 
Mode - CSS schema - Current Page size 

This article will discuss the first two, Incompatible HTML and Invalid HTML. The above example shows 
there are compatibility errors detected and HTML errors detected. 

Compatibility Checker for Incompatible HTML  
 You will need to work in Split View or the Compatibility errors will NOT show as errors. 

If you click the first icon, Incompatible HTML, you can choose to do one of the following: 

1. Go To Error 

http://www.htmlbasictutor.ca/code-validation-clean-code.htm
http://www.genealogy-web-creations.com/validation-tools.html
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2. Run Compatibility Checker 

3. Schema Options 

 

Figure 59: Incompatible HTML > Go To Error 

Selecting 'Go To Error' will take you to the error (pictured below). Hovering over the highlighted error 
will give you some additional information on the problem. 

 

Figure 60: Compatibility Error 

In this case, I am told that with the XHTML 1.0 Strict doctype, "target" is not permitted for the <a> tag. 
The target attribute is not allowed in strict doctypes which is what this site uses. If I delete it, the 
compatibility error disappears. Work your way through each of the errors that are shown. You can use 
the F9 key to go to the next error. Unsupported attributes, missing attributes, and improperly nested 
tags are all highlighted inline by the compatibility checker. 

You could also run 'Compatibility Reports' from the 'Tools' menu. You can choose to check one page, 
several pages or the entire site. 

Invalid HTML Code 
If you click the second icon, Invalid HTML, you can choose to do one of the following: 

1. Go To Error 

2. Run Compatibility Checker 

 

Figure 61: Invalid HTML > Go To Error 
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Selecting 'Go To Error' will take you to the error (pictured below). Hovering over the highlighted error 
will give you some additional information on the problem. 

 

Figure 62: Invalid HTML Error 

In this case you need to add a space and the closing forward slash <br /> If you are using the default 
XHTML doctype, then you need to remember XHTML elements must always be closed.  

Examples: 

This is not correct. 

<p>A line of text. 
<p>A line of text. 

This is correct. 

<p>A line of text</p> 
<p>A line of text</p> 

This is not correct 

<hr> 
<br> 

This is correct: 

<hr /> 
<br />  

If you are using the XHTML doctype, you can correct many of this type error by right clicking in Code 
View and selecting 'Apply XML formatting rules.' 

Additional Resources on Validation: 
• Validate HTML Code - HTML Code Validators 
• Validate CSS Code - CSS Code Validators 
• Validation Tools 

  

http://www.htmlbasictutor.ca/html-code-validators.htm
http://www.htmlbasictutor.ca/css-code-validators.htm
http://www.genealogy-web-creations.com/validation-tools.html
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Creating Your Dynamic Web Template 
Now that you have created your page, and you know that it validates you can save it as a Dynamic Web 
Template or DWT for short. There is a FREE Ebook available on Dynamic Web Templates written and 
made available by Tina Clarke.  I encourage you to download and use Expression Web DWT EBook 

What is a Dynamic Web Template? 
A Dynamic Web Template - DWT - is an HTML/XHTML based master copy of a web page that you create 
to contain formatting and page elements such as text, graphics, page layout, styles, and regions of a web 
page that can be modified. You can attach a Dynamic Web Template to the pages that are part of a web 
site, and that template defines the layout for those pages. A website can contain more than one DWT. 

Why it’s a good idea to use a DWT? 
One of the most important concepts of website design is to maintain a consistent look and feel for your 
site. Using a DWT makes this possible. As a webmaster you should attempt to provide: 

• Consistent navigation throughout your site  
• Consistent look throughout the site  
• Provide basic pages such as a Sitemap, Contact, About and Search pages. Your visitor should be 

able to reach your home page from any page on the site.  
• Provide copyright information and a disclaimer or terms of use page as well as a Privacy Policy. 

These are quite often found in the footer of a page. 

Creating a Dynamic Web Template – DWT 
Step 1: Before you can create a Dynamic Web Template you have to have a page to work with. Create 
your template as a HTML or XHTML document with all of the elements of the page that will be part of 
every page on your site - masthead, site navigation, footer.  Make sure it also includes any meta tags 
you want to use. Save the template and make sure it validates BEFORE you create your DWT. If you 
followed all of the previous steps, you will have created your basic template. 

Step 2: With your page open in EW > File > Save As > Save as type - dropdown button > Select Dynamic 
Web Template from the dropdown > Give the file a name site.dwt > Click Save 

http://any-expression.com/expression-web/ebooks/expression-web-dwt-ebook.htm
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Figure 63: Save As Dynamic Web Template 

Step 3: The DWT won't do you much good without editable regions - regions that can be changed on the 
pages the DWT is attached to. Once you save the page as a DWT, one editable region is created for the 
doctitle. You will need to create additional editable regions, for the content area, your keywords and 
description meta tags. 

 

Figure 64: Editable Region for <doctitle> 

NOTE: The editable region name must be all one word and in lower case. You can call it anything you 
want, however relating it to the placement on the page helps keep the various regions straight. 

Step 4: To create an editable region for your keyword and description meta tags, Copy and Paste the <!-- 
#BeginEditable "doctitle" --> just before your description meta tag. Copy and Paste the <!-- #EndEditable 
--> tag right after the keywords meta tag. Double click the 2nd occurrence of the doctitle tag and change 
it to headsection. 

 

Figure 65: Editable region for headsection 
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I also add an editable region for any scripting tags that might be a part of some of my pages.  

<!-- #BeginEditable "scripting" --> 

<!-- Scripting area here --> 

<!-- #EndEditable --> 

Step 5: Select all the text in the main text area of your DWT page > Right click with your mouse > Select 
manage editable regions from the drop down > In the region name box type  maincontent  > Click the 
add button > maincontent is added to your editable regions > Click the close button.  

 

Figure 66: maincontent editable region 

NOTE: In Code View, make sure the editable region is INSIDE you <div id="main-content"> or you will 
wipe out the div tag when you attach the DWT to your content pages.  

 

Figure 67: Code View - maincontent editable region 

You can now see that the text on your DWT page is surrounded by a yellow border and titled 
maincontent  

NOTE:  Expression Web 4.0 has a bug that causes the yellow/orange outline to NOT APPEAR around the 
editable region. You can still edit that region but you will not see the outline surrounding the area. THIS 
BUG HAS BEEN FIXED IN THE FREE VERSION OF EXPRESSION WEB 4. 
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Figure 68: Design View maincontent editable region 

Step 6: If your navigation is going to change from section to section, you will need to create an editable 
region for that area too. Once finished, save your page. 

Step 7: Now that you have created your DWT, you need to check and make sure it works correctly. Click 
on the new page icon > A new blank page is created for you > Click on Format from the top menu bar > 
Select Dynamic Web Template > attach dynamic web template. 

 

Figure 69: Attach Dynamic Web Template 

Click on site.dwt from the file list, and then click OK. Expression Web will tell you that 1 file has been 
updated. Expression Web has attached the DWT to your blank page. If everything looks OK, your DWT is 
ready to use.  
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What Is Search Engine Optimization - SEO? 
Search engine optimization (SEO) is the process of improving the volume or quality of traffic to a web 
site or a web page (such as a blog) from search engines via "natural" or un-paid ("organic" or 
"algorithmic") search results as opposed to other forms of search engine marketing (SEM) which may 
deal with paid inclusion. The theory is that the earlier (or higher) a site appears in the search results list, 
the more visitors it will receive from the search engine. SEO may target different kinds of search, 
including image search, local search, video search and industry-specific vertical search engines. This 
gives a web site web presence. ~ from Wikipedia ~ 

Search Engine Optimization (SEO) refers to a collection of techniques to improve your site's ranking in 
search engines, be it Google, Yahoo, or any of the others.  

One of the new features of Expression Web 4.0 includes Search Engine Optimization tools. The SEO 
Checker feature of Expression Web helps you understand and apply search engine ranking best practices 
to obtain the highest possible search engine ranking. 

The SEO Checker analyzes specific areas of your site and specific elements in the individual pages of 
your site. Using the following guidelines can help improve the search-engine ranking of your site.  

IMPORTANT: Before you attempt to use the SEO Checker and SEO Report, I encourage you to learn at 
least the basics of Search Engine Optimization by following some of the basic tips listed in the article 
below.  

How Does Search Engine Optimization (SEO) Work? 
A user goes online and types keywords into the search engine of his choice - Google, Yahoo, or Bing. 
The user may be looking for information such as how to design a web page or a product like a new 
wireless router. The search engine then returns a list of pages, with each ranked according to its 
relevance to the user's search query. Search engines use a web crawler or spider to discover and index 
pages. An important task for you, the web developer is to make sure that search engine crawlers can 
find and index information on your page so that a search query will guide users to that page. 

Pages that have been optimized for search engines follow coding practices that provide relevant 
information to search engines quickly. Read How Search Engines Read Web Pages  

As you work with each page, you need to do YOUR research as to what keywords users search for. Some 
tools you can use for your research include: 

• Good Keywords 
• FREE keyword suggestion tool 

Basic Search Engine Optimization Techniques 

http://en.wikipedia.org/wiki/Search_engine_optimization
http://www.htmlbasictutor.ca/search-engine-read-web-pages.htm
http://www.goodkeywords.com/
http://freekeywords.wordtracker.com/
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There are some basic SEO best techniques you can follow that will help with your search engine 
optimization. They include BUT are not limited to: 

Page Titles 
Create unique and accurate page titles that are relevant to the content of that particular page. They 
should be short and descriptive using about 60 to 65 characters. Remember, that not everyone will 
enter your site through your "front door." Some may choose a "back door" or the "kitchen door." Treat 
each and every page as an entry point to your site with unique content and a unique page title. 

The page title goes between the <title></title> tags within the head section of your page. The page title 
tells BOTH the users and the search engines what the page is about. 

Page titles can be added from within Expression Web by right clicking on the page and selecting 'Page 
Properties' > 'General' tab and typing the "Title" in the appropriate box. 

Example: <title>Search Engine Optimization - SEO - Search Engine Optimization Techniques</title> 

Meta Tag for description 
A page's description meta tag gives Google and other search engines a summary of what the page is 
about. The description meta tag goes within the head section of your page and should be limited to 150 
to 200 characters. 

<meta name="description" content="Brief description of your site goes here." 
/>  

Description meta tags are important because Google and the other search engines might use them as 
the description that appears under a page's title and above a page's URL in a search result. 

Good practices for the description meta tag include" 

Accurately summarize the page's content. 

Use unique descriptions for each page. 

Use the exact title of your page within the description meta. 

Page descriptions can be added from within Expression Web by right clicking on the page and selecting 
'Page Properties' > 'General' tab and typing the "Page Description" in the appropriate box. View 
Screenshot 

Meta Tag for keywords  
As of September 2009, Google no longer uses the keyword meta tag in ranking web search results and 
support for its use has dwindled as it was easily abused. If you choose to use the keyword meta tag, it is 
placed in the head section of your page and would look like this. 

<meta name="keywords" content="keyword, keyword,keyword" />  

http://www.expression-web-tutorials.com/images/search-results.jpg
http://www.expression-web-tutorials.com/images/search-results.jpg
http://googlewebmastercentral.blogspot.com/2009/09/google-does-not-use-keywords-meta-tag.html


Expression Web 4.0 Tutorials from Install to Publish and More Page 79 
 

The keywords you use should appear on your pages and separated by commas. This tag should NOT be 
used to stuff with keywords and limited to approximately 150 characters.  

Page keywords can be added from within Expression Web by right clicking on the page and selecting 
'Page Properties' > 'General' tab and typing the "Keywords" in the appropriate box. 

File Names 
The file names you choose for your pages (and images for that matter) should reflect the content of the 
page and the keywords for that particular page. The file name should be short using two or three of your 
keywords and be unique for each page of your site.  

You should never use spaces in your files name and hyphens are preferred over underscores. Do not use 
overly long file names for either your pages or your images. 

If you use spaces in your file names, they will show as my%20file.html. Instead use my-file-name.html.  

Heading Tags 
Use heading tags appropriately to give structure to your page NOT to style the presentation. There are 
six sizes of heading tags, beginning with <h1>, the most important, and ending with <h6>, the least 
important.  It is NOT likely you will use all six heading tags on a page. You can read more about heading 
tags in this article by James Huggins. 

Good practices for heading tags include: 

Imagine you're writing an outline. 

Use headings sparingly across the page. 

Use css to style the look of your heading tags. 

Alt Attribute 
The "alt" attribute allows you to specify alternative text for the image if it cannot be displayed for some 
reason. For those folks who are using alternative technologies, such as a screen reader, the contents of 
the alt attribute provide information about the picture.  The "alt" attribute is REQUIRED in order for 
your page to validate. The alt text should give a brief but accurate description of the image using your 
keywords if it makes sense.  

It is also good practice to store your images in their own directory rather than have them spread out 
throughout your site. 

Alt tags can easily be added in Expression Web by right clicking on an image, selecting 'Picture 
Properties' and on the 'General' tab under 'Accessibility' typing 'Alternate Text' in the appropriate box. 

Example: <img alt="Screenshot Page Editor Options General tab." height="225" 
src="images/ew4-peo-general-tab_small.jpg" width="200" /> 

http://www.genealogy-web-creations.com/heading-tags.html
http://www.genealogy-web-creations.com/heading-tags.html


Expression Web 4.0 Tutorials from Install to Publish and More Page 80 
 

Title Attribute 
Unlike the TITLE element, which provides information about an entire document and may only appear 
once, the title attribute may annotate any number of elements. The title attribute specifies extra 
information about an element and  is most often shown as a tooltip text when the mouse moves over 
the element.  

To add the title attribute to hyperlinks in Expression Web, highlight the text you wish to use, and right 
click or hold down the Ctrl key + K and select hyperlink. In the dialog box, either browse to the file you 
want to link to OR type the url of the page in the Address: field. Click the 'Screen Tip' button and type 
the text you wish to use.  

IMPORTANT: There is a bug in Expression Web 4.0 that causes the hyperlink dialog box to lose focus if 
you are working in Design View. Once you click OK from the Screen Tip text box, EW will bring up the last 
open window you were working with. You will need to return to the EW editing window to continue. 
This does not happen if you are working in code view and simply type the title attribute with the text 
you wish to include.  

Example: <a title="Screenshot: Setting up Expression Web Page Editor Options > General 
tab." href="images/ew4-peo-general-tab.jpg"> 

Content 
While all of the tips listed in the previous section will help with Search Engine Optimization, the content 
of your site is the meat of the site. According to Google, you should "create a useful, information-rich 
site, and write pages that clearly and accurately describe your content. Think about the words users 
would type to find your pages, and make sure that your site actually includes those words within it."   

You might find these articles helpful: 

• Website Content  
•  Developing Quality Content  
• Content SEO - Does Content Play a Role in SEO?  

In order to be found by the search engines, your content must be readable by them. If your pages are 
full of flash movies, images and such with very little content, there will not be much there for the spiders 
to index when they visit your site. So take your time, do your keyword research and develop your 
content around those well researched keywords.  

Remember, that your visitor can enter through any door of your site not just your "front door" or Home 
Page. Spend as much time developing the content for those other doorways as your front door. 

Summary 

http://www.website-development-training.com/website-content/
http://www.website-development-training.com/developing-quality-content/
http://www.gnc-web-creations.com/content-seo.htm
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Now that you know a little more about some of the basics you need to do to optimize your site for the 
search engines, you can use the newest tools available in Expression Web 4 SEO Checker and SEO 
Reports. 

To learn more about Search Engine Optimization, make use of the resources listed below. 

SEO Resources 

• Google's Search Engine Optimization Starter Guide 
• Search Engine Optimization (SEO) from Google 
• FREE SEO Techniques Training Class 
• SEO Techniques - SEO Optimization Techniques EBook 
• Search Engine Optimization for Bing 
• Yahoo! Search Content Quality Guidelines 

  

http://www.expression-web-tutorials.com/ew4/seo-checker.html
http://www.expression-web-tutorials.com/ew4/seo-checker.html
http://static.googleusercontent.com/external_content/untrusted_dlcp/www.google.com/en/us/webmasters/docs/search-engine-optimization-starter-guide.pdf
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=35291
http://www.gnc-web-creations.com/seo-optimization.htm
http://www.gnc-web-creations.com/seo-techniques.htm
http://www.bing.com/toolbox/blogs/webmaster/archive/2009/09/03/search-engine-optimization-for-bing.aspx
http://help.yahoo.com/l/us/yahoo/search/basics/basics-18.html


Expression Web 4.0 Tutorials from Install to Publish and More Page 82 
 

Using the Expression Web SEO Checker and 
Report 
IMPORTANT: Before you attempt to use the SEO Checker and SEO Report, I encourage you to learn at 
least the basics of Search Engine Optimization. You will also have more manageable results if you select 
the pages you want to run the report on combined with the filters OR simply run the checker on the 
page you are working on.  

Search Engine Optimization (SEO) refers to a collection of techniques to improve your site's ranking in 
search engines such as Google or Yahoo or any of the others. One of the newest features in Microsoft 
Expression Web 4 is the SEO Checker which analyzes your site against the best practices for getting the 
highest possible search-engine rankings for your site.  

What does the SEO Checker do?  
The Expression Web SEO Checker will analyze your site using techniques similar to what a search engine 
would use. It then provides helpful information to so that you can optimize the pages of your site for 
maximun search engine ranking. The detailed report generated will look something like the graphic 
shown below. 

 

Figure 70 - SEO Report. 

Hovering your mouse over the 'Problem Summary' listing will give you  more details on the problem 
listing as you can see by the enlarged thumbnail. 

The SEO Checker report lists the following classes of SEO messages: 

NOTE: Clicking on the links below will take you to the online help for Expression Web 4 with many more 
details on each of the items listed. The same information is available from the 'Help' menu > 'User 
Guide' or clicking F1. 

http://www.expression-web-tutorials.com/search-engine-optimization.html
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Content is not where search engines expect to find it. These rules identify content or markup that is not 
located where search engines are likely to look for it.  

The <title> tag is missing 
The <img> or <area> tag does not have an 'alt' attribute with text 
The <noscript> tag is missing  
The <title> tag contains placeholder content that provides no search benefit  
This page contains no <h1> tag  

Content or markup follows patterns that may be associated with deceptive practices. These rules 
identify content or markup that search engines may perceive as using practices designed to artificially 
inflate the search rankings of a page or a site.  

The contents of the <meta name="description"> tag are too long 
The <meta name="keywords"> tag contains multiple instances of a single term 
The <meta http-equiv="refresh"> element is being used for redirection  
The title and description for the page are identical  

Content or markup interferes with the ability of search engines to analyze a page. These rules identify 
content or markup that prevents search engines from accurately analyzing your site.  

The <body> tag is missing  
The <title> tag is not defined in the <head> tag section  
The page is not well-formed The <html> tag is missing  
The <h1> is not inside the <body> tag section  

Content or markup reduces the appeal of a page in search-engine results. These rules identify content or 
markup that search engines can analyze only partially.  

The <title> tag contents are too long.  

The description for the page is missing. 
The <meta name="description"> tag contents are too short  
The <meta name="description"> tag should be declared only once in a page  

Content causes search engines to consider two or more pages to be relevant to the same search term. 
These rules identify content or markup that may cause search engines to report that more than one 
page is relevant to a search term. 

A URL that points to a directory should end with a slash mark (/) 
The hyperlink ends in an ampersand  
The title is not unique  
The anchor is not formatted consistently  
The hyperlink contains a session ID  

http://msdn.microsoft.com/en-us/library/ff723979%28v=Expression.40%29.aspx
http://msdn.microsoft.com/en-us/library/ff723900%28v=Expression.40%29.aspx
http://msdn.microsoft.com/en-us/library/ff724017%28v=Expression.40%29.aspx
http://msdn.microsoft.com/en-us/library/ff723963%28v=Expression.40%29.aspx
http://msdn.microsoft.com/en-us/library/ff723932%28v=Expression.40%29.aspx
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Content or markup blocks search engines from analyzing your site. Blocked-content rules identify 
content or markup that blocks search engines from analyzing your site.  

The hyperlink contains an invalid character. 
The hyperlink contains a nofollow attribute value  
The hyperlink contains too many query string parameters  

What the SEO Checker Does Not Do. 
While the SEO Checker can make you aware of problems and help you correct problems with 
the markup and content of your site, there are other things you will need to do to optimize your 
site for the search engines. Ask yourself these questions: 

• Do the search engines see your site as two separate sites www.my-domain.com or my-
domain.com?  
 
If you type site:my-site.com/ into the search box, do you get the same number of results if you 
type site:www.my-site.com/ into the search box? If not see Google Canonical problems - www 
versus non.www. 

• Have you taken care of building incoming links to your site from other sites? You should be 
linking to pages within your site as well as having external sites link to your pages. 

• Have you done the keyword research for your content? Don't guess, use some of the online 
tools to research what terms people use in searching for your content and use those keywords 
in developing your content. 

• Have you used descriptive file names to name your pages as well as your images? Remember 
NOT to use spaces but hyphens in naming your files. 

• And last but not least, have you developed unique and original content for your pages. 

To generate an SEO report  
Step 1: Do one of the following: 

http://msdn.microsoft.com/en-us/library/ff724044%28v=Expression.40%29.aspx
http://www.genealogy-web-creations.com/www-versus-non-www.html
http://www.genealogy-web-creations.com/www-versus-non-www.html
http://www.expression-web-tutorials.com/search-engine-optimization.html#file-names
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• With your site open, click 'Tools ' on the menu, then select 'SEO Reports.' The 'SEO Checker' 
dialog box is displayed.  

 

Figure 71 - SEO Checker dialog box 

• Click 'Check' to start generating the SEO report. 
• With your site open, on the 'Panels' menu, click 'SEO.' The SEO panel is displayed. 

Click to open the SEO Checker dialog box.  

Step 2: In the SEO Checker dialog box, specify the pages that you want to analyze. 

• To specify all pages in a site, under 'Check where', click 'All pages.' NOTE: If you have a large 
site, this can give you an overwhelming report. 

• To specify only the pages you have open, under 'Check where', click 'Open pages.' 
• To specify pages from the 'Folder List,' select the pages that you want to check, and then, under 

'Check where', click 'Selected pages.' If you do not have the Folder List showing, click the 
'Panels' menu, and select Folder List.  

• To specify the active page, under 'Check where', click 'Current page.' 

Step 3: Specify the types of items that you want to show in the SEO report.  

• To include items that are considered errors, select the 'Errors' check box.  
• To include items that you may not have to adjust, select the 'Warnings' check box.  

Step 4: Click 'Check.' The check may take some time to complete, depending on the options that you 
selected and the size of the site. The results are displayed in the SEO panel (shown below) when then 
check is completed.  
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Figure 72 - SEO Report. 

 
The results may be sorted by clicking on any column label.  

To apply a filter to an SEO report  

In the SEO report, on the column label, click and select the filter condition that you want to apply to 
the list. The filter settings are saved when you close the site. If you can't find files in a new report, you 
may have filters applied from a previous session. You can create custom filters for your SEO report. For 
more information, see Customizing filters.  

Example: If you have a folder named _includes and one named gallery and you want to exclude the 
contents of those folder from the results, click on the page label drop down and select "custom.' 

 

Under 'Show rows where': Page; select does not contain and type in _includes. Tick the Or does not 
contain. Type in gallery. Click OK. 

Your list now shows none of the files within the _include folder or the gallery folder. Each of the labels 
will allow you to apply two filters. 

http://msdn.microsoft.com/en-us/library/ff723966%28v=Expression.40%29.aspx
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To remove a filter from an SEO report  
Right-click anywhere in the report and then click 'Clear Filters.' 

Understanding the SEO Report 
When you generate a report, the SEO panel contains the following columns: 

• Page - Lists the page that contains an issue and the location of that page. 
• Line -  Lists the number of the line in Code view that contains the issue. 
• Issue Type -  Lists the type of issue, either Error or Warning. 
• Problem Summary - Describes the code error or the reason the code is incompatible with the 

schema. The content of this column also appears in a ScreenTip when you point at a row in the 
panel or when you point at the source of the problem in Code view. 

To sort the list of results, on the Search Engine Optimization tab, click the name of a column. To reverse 
a sorted list, click the name of the column again. You can also rearrange columns by dragging them. 

SEO panel buttons 

 

Figure 73 - SEO panel buttons 

• To open the SEO Checker dialog box, click Run SEO Checker. 
• To open the web page that contains the next or previous result in the list, and to highlight the 

issue, click Next Result  or Previous Result. To go to the next issue on an open page, press F9. 
• To recheck pages that were checked and have changed, click Refresh Changed Results. 
• To sort the list of results, click the name of the column that you want to sort by. To reverse a 

sorted list, click the name of the column again. To restrict the results to those that fit the criteria 
you select, click the down arrow  that appears in the heading of a column and select a criterion 
by which to filter the results. 
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• When you right-click a row, a shortcut menu provides the following additional options:

 

Figure 74 - SEO shortcut menu 

o Go to Page - Opens the web page that contains the result and highlights the issue. 
o Problem Details -  Opens the Problem Details dialog box, which contains more 

information about the selected issue. 
o Learn More -  Opens the help topic for this issue type, which contains more details and 

suggestions about how to correct the issue. 
o Select Resulting Files in Folder List - Locates the selected pages in the Folder List panel. 
o Clear Results  -  Clears the results list. 
o Refresh Changed Results -  Rechecks the specified pages that have changed. 
o Copy Selected Results - Copies the selected results of the report as a table. 
o Clear Filters -  Clears all filter criteria and sets the Filter menu of every column to All. 

  

Problems Details and Fixes SEO Reports 
While the SEO Reports can be a tool for correcting problems with your site, it is just that, a tool. If I use 
this site an an example and run the SEO Reports with the errors setting ticked and All Pages ticked, I get 
2,650 searchability problems in 235 pages. Overwhelming to say the least!  

The problems listed below are just some of those you might encounter while running the SEO Checker 
on your site. 

The anchor text contains values that provide no search benefit  
Problem Summary message reads: "The <a> tag text is too general to provide search benefit." 

If I hover over one of the listings OR right click and select 'Problem Details' , I get "The <a> tag contains 
the text 'Home', which provides no search benefit. Consider changing the link text to provide 
meaningful, descriptive link text." 

Clicking on 'Help Topic', gives me the following explanation: 
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The <a> tag appears to contain generic text, such as "link" or "click here." If a hyperlink points to content 
that is relevant to the site, the search ranking of the site may be reduced unless the anchor text 
accurately describes the target of the hyperlink. Search engines use the contents of <a> tags to provide 
details about the page to which the <a> tag links.  

Many of this type of Problem Summary message relates to my menu which has to be short to fit in the 
allotted space. What can I do to help the search engines? I add a title attribute to the hyperlink. While 
this will not change the SEO Report problem summary listing, it will help the search engines understand 
what the text link points too. 

The description for the page is missing.  
Problem Summary message reads: "The description is missing." 

If I click on the 'Help Topic', I get the following explanation: 

Because search engines typically display the content of the <meta name="description"> tag in search 
results, each page should have a single, unique description that accurately describes the contents of the 
page.  

Since the Page label column indicates the problem is with one of my included menus, it is not one I need 
to be concerned about. However, you should make sure that all your pages that should have a page 
description do. 

Hyperlinks that point to a directory should end in a slash (/) 
Problem Summary message reads: "Hyperlinks that point to a directory should end in a slash (/)" 

The Problem Details explain that most pages in a site contain at least one hyperlink to a URL that points 
to a directory (such as www.expression-web-tutorials.com/ew4/). If several hyperlinks in which the URL 
target is the same directory are formatted differently, they may be treated as separate links. What is 
delivered to the browser in the default page for that directory i.e. index.html or default.html 

The <meta name="keywords"> tag contents are too short 
Problem Summary message reads: file-name.html, line #: The contents of the <meta 
name="keywords"> tag are too short. If the contents of the <meta name="keywords"> tag are too short, 
search engines may not consider them to be relevant. Consider lengthening the contents of the <meta 
name="keywords"> tag.  

Support for the keyword meta tag has  dwindled and Google no longer uses this tag in ranking web 
search results. If you choose to use it, limit it to 150 characters including spaces, and include only those 
words you use in your content. 

The <title> tag contents are not unique within the site 
Search engines use the contents of the <title> tag both to provide some of the details about the site 
contents and to provide specific details about the contents of a page. Each page should have a single, 

http://www.expression-web-tutorials.com/search-engine-optimization.html#title-attribute
http://www.expression-web-tutorials.com/search-engine-optimization.html#description-meta
http://www.expression-web-tutorials.com/search-engine-optimization.html#description-meta
http://www.expression-web-tutorials.com/search-engine-optimization.html#keyword-meta
http://www.expression-web-tutorials.com/search-engine-optimization.html#page-title
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unique title contained inside a <title> tag inside the <head> tag section of the page. It should be no 
longer than 65 characters. 

The <img> or <area> tag does not have an 'alt' attribute with text  
The alt attribute is meant to be used as an alternative text if the image is not available and is required in 
order for your page to validate. The alt attribute text is also used by audio readers for the visually 
impaired. However, if you are using spacer graphics or decorative images they should contain an empty 
alt attribute.  

The alt text should give a brief but accurate description of the image using your keywords if it makes 
sense.  

The <noscript> tag is missing 
Every page that contains a <script> tag should have a corresponding <noscript> tag. Search engines will 
not index the contents of a <script> tag. If code inside a <script> tag generates search-relevant page 
content, that content may not be analyzed by search engines at all. 

The <noscript> tag is used to provide an alternate content for users that have disabled scripts in their 
browser or have a browser that doesn’t support client-side scripting. 

As an example, the footer of this site uses a script to generate the copyright information so that it 
updates automatically. The <noscript> tag provides the same information in text format. Or simply use 
<noscript>Your browser does not support JavaScript!</noscript> 

This page contains no <h1> tag  
In semantic web design, headings provide important organizational and summary information. Each 
page should have a single <h1> tag that summarizes the contents of the page. If the page contains a 
significant amount of text, it should be organized with <h2> through <h6> subheadings that summarize 
and categorize the text that they precede. Search engines rely on correctly used headings to determine 
the organization and contents of a site.  

Any page that does not have an <h1> tag is going to generate this error including any include pages. Use 
the filters to filter out these pages. 

Your <h1> heading tag should match your title tag <title> tag and there should be only ONE <h1> tag on 
your page. 

Summary 
The SEO Checker is just a tool for you to use in evaluating whether you have followed good Search 
Engine Optimization practices in building your pages. It can be a little over zealous in giving you a listing 
of the problems so you will need to filter the results in the report. 

http://www.expression-web-tutorials.com/search-engine-optimization.html#alt-attribute
http://www.expression-web-tutorials.com/search-engine-optimization.html#heading-tags
http://www.expression-web-tutorials.com/search-engine-optimization.html
http://www.expression-web-tutorials.com/search-engine-optimization.html
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Do some research and learn what are the best practices to follow in designing your pages. Soon, it will 
become second nature to make sure such things as page titles, descriptions, semantic markup and using 
your keywords are part of your web development strategy.  

Don't try and fix everything that needs fixing on your site at one time. You will become overwhelmed. 
Take one page at a time and fix the problems with that page. Go on to the next one.  

One online class that I can highly recommend and that is FREE is the SEO Training Class taught by Cricket 
Walker. 

Additional SEO Resources  
• Google's Search Engine Optimization Starter Guide 
• Search Engine Optimization (SEO)  
• Yahoo! Search Content Quality Guidelines  
• How to Improve the Position of Your Website in Yahoo! Search Results 
• Search Engine Optimization for Bing  

  

http://www.gnc-web-creations.com/seo-optimization.htm
http://static.googleusercontent.com/external_content/untrusted_dlcp/www.google.com/en/us/webmasters/docs/search-engine-optimization-starter-guide.pdf
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=35291
http://help.yahoo.com/l/us/yahoo/search/basics/basics-18.html
http://help.yahoo.com/l/us/yahoo/search/indexing/ranking-02.html;_ylt=AhbstETAzH86bN8dSf_J8rD.YHhG
http://www.bing.com/toolbox/blogs/webmaster/archive/2009/09/03/search-engine-optimization-for-bing.aspx
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Working with Images in Expression Web 
Before you insert a graphic image into any newly created page, first save the page and give it a name - 
File > Save or Ctrl + S. While this is NOT required, some users have had problems with paths not 
resolving correctly when the page has been saved and named for the first time after images were added. 
Therefore it is considered good practice to save the page before inserting images, hyperlinks, and style 
sheets.  

This tutorial also assumes your images are already located in your website folder. If they are not, you 
will either need to import them into the web, or save them as part of the web. 

Importing Your Images 
• With your site open in Expression Web, on the File menu > Import > File or Folder 
• In the ‘Import’ dialog box click Add File or Add Folder >  
• In the ‘Add File to Import List’ that pops up, browse to the  folder where the files are located  
• Hold down the ctrl key and click all files you want to import > Click OK 

 

Figure 75 - Import Files dialog box 

Once you click OK, you will see all of the files you selected for import now listed as part of your new 
web.  

NOTE: If you store your images in an image folder, you can drag the images you have just imported into 
that folder. 
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Inserting Images into a Web Page 
There is a new feature in Expression Web 4.0 SP2 called 'Thumbnail Previews' which is located at the 
top of the Folder List. It gives information on the currently selected image, such as: a small thumbnail, 
dimensions of image and file size. You can click <img> to copy an img tag to the clipboard which can 
then be pasted into code view and will look like this: 

<img src="2nd-edition-cover.jpg" width="329" height="452" alt="" /> 

If you click CSS,  you can copy the css properties to the clipboard, which can then be pasted into your 
style sheet and using the same imag as above would look like: 

background-image: url("2nd-edition-cover.jpg"); width: 329px; height: 
452px; 

 

Figure 76 - Thumbnail Preview 

To insert an image into your web page, place your cursor on the page where you want the image to 
appear and do one of the following: 

• From the Insert menu > Picture > From File > Select the image > Click Insert 
• Drag the picture from the Folder List panel or Site View into the Design view of your page.  

The Accessibility Properties dialog box allows you to insert ALT text and a Long Description if needed.  

• Alternate text makes your image accessible to screen readers. It also is visible in some browsers 
when the graphic is downloading, when it can't be found, or when a site visitor moves the 
pointer over it.  
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• See, When to Provide Long Descriptions for more information on this accessibility feature. 

 

Figure 77 - Accessibility Properties Dialog Box 

Check in code view and you should see something like this - 

<p><img alt="Screenshot of Accessibility Properties Dialog Box." 
src="images/accessibility-properties.png" width="408" height="127" /></p> 

If the image you are inserting is NOT already located within your website folder, when you save the 
page, the embedded files dialog box pops up. Click Change Folder and select the folder where you want 
your images stored. Click OK > OK and the images will be stored in the correct folder and now be a part 
of your website. 

 

Figure 78 -- Save Embedded Files dialog box. 

About the Picture Properties Dialog Box 

The Picture Properties dialog box gives you access to the most commonly-used picture attributes. Right 
clicking or double clicking the image will bring up the Picture Properties box. 

The following are the options available from the Picture Properties dialog box in Expression Web. There 
are two tabs - General (Figure 80 - Picture Properties General Tab) and Appearance (Figure 81 - Picture 
Properties Appearance Tab). 

http://webaim.org/techniques/images/longdesc#when
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Figure 79 - Picture Properties General Tab 

 
 

General Tab 

PICTURE: folder/file name of graphic image 

ACCESSIBILITY: 
Alternate Text: Type the text you want to be displayed for pictures when the graphic is downloading, 
when it can't be found, or when a site visitor moves the pointer over it. This text will also be used by a 
screen reader if your viewer is using one. Creating Effective Alternative (alt) Text  

Long Description:  There are times a few words may not be enough to describe your image. Charts and 
graphs are examples. Click Browse to select a file that contains a longer description of the picture. For 
more details on using long description.  

HYPERLINK: 
Location: If you want to link your image to a web page or larger image, you insert the hyperlink here. 
You may also use Insert > Hyperlink 

Target Frame:  If the current page is a frames page, this option indicates which frame the link should be 
displayed in OR you can choose to have the image or page open in a new window. 

http://www.webaim.org/techniques/images/alt_text.php
http://www.webaim.org/techniques/images/longdesc.php
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Figure 80 - Picture Properties Appearance Tab 

 
 

Appearance Tab 

WRAPPING STYLE:  Specify how the picture floats in the page. Your choices are None, Left, or Right. 
(Rather than use this option, you should create a style for floating your images and apply the style.) 

LAYOUT: 
Alignment: Specify how you want the picture to be aligned on the page. Illustrating Image Alignment 

Border Thickness:  Set the border thickness in pixels for the picture. Better yet, add the border to your 
image using a graphic editor. 
Horizontal margin:  Set the left and right margin width in pixels. (This should be specified in your style 
sheet.) 
Vertical margin: Set the top and bottom margin width in pixels.  (This should be specified in your style 
sheet.) 

SIZE: Expression Web automatically sets width and height properties for the image based on the actual 
dimensions of the picture.  Rather than resize your image by changing these dimensions, resize the 
image using your graphic editor.  

EXAMPLE: If I had indicated that I wanted my image left-aligned, with a 1px border, and a 4px horizontal 
and vertical margin, Expression Web would have created the following style: 

.style1 { 
float: left; 



Expression Web 4.0 Tutorials from Install to Publish and More Page 97 
 

border-style: solid; 
border-width: 1px; 
margin: 4px; 
} 

and my html code would look like this 

<p><img alt="Screenshot of Picture Properties Dialog Box." 
src="images/picture-properties-appearance.jpg" width="442" height="391" 
class="style1" /></p> 
 
I would then rename the style to .imglft and reuse it anytime I wanted.   

NOTE:  

• If you are going to change the dimensions of an image, it is best to do so using an image editor 
NOT by changing the dimensions in your HTML code.  WHY? Because the browser still has to 
download the full size image before displaying it.  

• If you are going to add a border to your image, which is also best done in an image editor.  

 

Using Auto thumbnail 
You can use Microsoft Expression Web to quickly create a smaller thumbnail-sized version of a picture to 
use on your webpage which is then automatically linked to a larger image. It is preferable to optimize 
your images and create your thumbnails within a graphics program but you can use this in a pinch.  

Check doctype declaration 
Make sure that you are using a complete doctype declaration on your page.  

http://www.w3schools.com/tags/tag_DOCTYPE.asp
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Set the Default Properties for thumbnails 
1. Tools > Page Editor Options > Auto Thumbnail Tab 

 

Figure 81 - Page Editor Options AutoThumbnail tab 

2. In the Set box, choose your option then type a value in pixels. I use 200px.  
3.  I do NOT select a border thickness as I specify in my external sheet no border around body 

images so I do not have the ugly blue border around hyperlinked images. 
 body img { border: 0px; text-decoration: none;} 

4. I also do NOT choose to have a beveled edge as that is a rather out of date look. 

Create a thumbnail picture 

1. Insert the full size image into your page Insert > Picture > From File OR you can drag and drop 
the image. NOTE: Make sure you save your page before you start inserting the images or the 
path to your images may not be correct. 
In the Accessibility Properties dialog box, insert an alternate description for the image. 

 

Figure 82 - Accessibility Properties. 
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2.  Right click the image > Show Pictures Toolbar  

3. On the Pictures toolbar > click the Auto Thumbnail button. (2nd icon from the left)  OR 
right click the image and choose Auto Thumbnail. 

4. To save the thumbnail picture File > Save  

5.  In the Save Embedded Files dialog box, set the options you want and then click OK.  
NOTE: I keep all of my images in a folder called images so I browse to that folder to save the 
thumbnail image. 
The following lines of code are added to your html code: 
 
<a href="images/barnett-loni-jones-kids.jpg"><img alt="Picture of 
Barnett and Lonie Jones and children." src="images/barnett-loni-jones-
kids_small.jpg" width="200" height="276" /><!-- 
MSComment="autothumbnail" xthumbnail-orig-
image="file:///C:/Users/Patricia Geary/Documents/My Web Sites/test-
auto-thumbnail/images/barnett-loni-jones-kids.jpg" --></a> 

 
NOTE: file names for images should NOT contain spaces or special characters.  
If you have a lot of pictures this could add a considerable amount of unnecessary code to your 
page. 

 

Figure 83 - Code for 3 images BEFORE optimization. 

6. The code created using the Auto Thumbnail feature will validate BUT you can clean up that code 
considerably and do no harm to the images or your display. 
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With your page open in Code View > Right Click > Optimize HTML 

 

Figure 84 - Optimize HTML 

 

 

Figure 85 - Code for 3 images after optimization 

NOTE: The code highlighted below is what will be removed from each image. 

<a href="images/barnett-loni-jones-kids.jpg"><img alt="Picture of Barnett and 
Lonie Jones and children." src="images/barnett-loni-jones-kids_small.jpg" 
width="200" height="276" /> <!-- MSComment="autothumbnail" xthumbnail-orig-
image="file:///C:/Users/Patricia Geary/Documents/My Web Sites/test-auto-
thumbnail/images/barnett-loni-jones-kids.jpg" --> </a> 

 
Using the auto thumbnail feature is NOT the best way to optimize your images for use on the web. 
Instead use your favorite graphics editor. If you don't have one installed on your computer there are 
free ones available such as Irfanview and paint.net. 

Problems with HTML Strict doctype declaration 

NOTE: If you use the HTML Strict doctype shown below, your page will NOT validate with the code used 
by the auto thumbnail feature.  

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" 
"http://www.w3.org/TR/html4/strict.dtd">  

http://www.irfanview.com/
http://www.getpaint.net/
http://www.getpaint.net/
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Optimizing the code will NOT remove the offending code. 

XHTML Strict doctype declaration 

If you change your doctype declaration to an XHTML Strict doctype, the page will validate and optimizing 
the code will remove the thumbnail statement 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> <html 
xmlns="http://www.w3.org/1999/xhtml">  
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Working with Hyperlinks 
Hyperlinks or links are found within nearly all web pages. Links allow your user to click and go to a 
different page, a place within a page, an image or another location on the Internet entirely. A hyperlink 
can be a word, a group of words, or an image that when clicked on will take you to a new document or a 
place within the current document. 

Anchor Tags 
HTML uses the <a> (anchor) tag to create a link to another document. An anchor can point to another 
html page, an image, a text document, or a pdf file among others. 

Example of an anchor tag:  

<a  href="url">Text to be displayed as link</a> 

The <a> tag is used to create an anchor to link from, the href attribute is used to address the document 
to link to, and the words between the open and close of the anchor tag will be displayed as a hyperlink. 

When you move the cursor over a link in a Web page, the arrow will turn into a little hand.  The 
default of the anchor tag is to go to the top of the document it points to. 

A URL is an address that specifies a protocol, Web server, and file path. There are two types of URLs: 
absolute and relative. An absolute URL contains a full address while a relative URL is missing one or 
more parts of the address. However, the web browser obtains the missing information from the page 
that contains the URL. 

EXAMPLE: Absolute Path Source 

<a href="http://www.expression-web-tutorials.com/">Home</a> 

EXAMPLE: Relative Path Source 

<a href="index.html">Home</a> 

Both of the examples used will take you to the Home Page of my site Expression Web Tutorials and 
Templates. The browser will simply add the missing parts of the url for the relative link. 

NOTE: I tend to use absolute urls for the menus within my site or any reference to the Home Page.  For 
links to images or other pages within the site, I use relative urls. 

Bookmarks or Named Anchors (HTML anchors) 

http://www.expression-web-tutorials.com/
http://www.expression-web-tutorials.com/
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Named anchors are called bookmarks in Expression Web. The name attribute specifies the name of an 
anchor and is used to create a bookmark inside an HTML document. If you want the browser to go to a 
particular section of a web page, you add a bookmark to that section and then add a hyperlink that uses 
the bookmark as its destination. When the site visitor clicks the hyperlink, the browser scrolls to the part 
of the page that contains the bookmark. Bookmarks are not displayed in any special way. They are 
invisible to the reader. 

Example of a named anchor tag:  

<a  name="anchor">Text to be displayed as link</a> 

The name of the anchor can be any text you care to use. However, it should not have spaces in the 
name. Use a hyphen or underscore and all lowercase letter. Expression Web uses an underscore as the 
default. 

Example: <a name="ew-books"></a>Expression Web Books 

NOTE: If you highlight the text before you add your bookmark, the Expression Web Books part of the 
code above is going to be styled as a hyperlink. To avoid this happening, I place the cursor just before 
where I want the named anchor and insert the bookmark. 

To link directly to the " ew-books " section of the page on Expression Web Resources, add a # sign and 
the name of the anchor to the end of a URL, like this: 

<a  href="http http://www.expression-web-tutorials.com/resources.html#ew-books">Expression Web 
Books</a> 

or like this if you are creating a link to a place in the same document 

<a  href="#ew-books">Expression Web Books</a> 

Add or Remove a Bookmark in Expression Web 
You can add a new bookmark and manage existing bookmarks in the current web page by using the 
Bookmark dialog box. 

When you bookmark a selection of text, the text displays with a dashed underline in Design view. 

 

<a name="10-bible">10. Family Bible,</a> C. H. Davis, Pasadena, California. 

 

<a name="10-bible"></a>10. Family Bible, C. H. Davis, Pasadena, California. 

http://www.expression-web-tutorials.com/resources.html#ew-books
http://www.expression-web-tutorials.com/resources.html#ew-books">Expression


Expression Web 4.0 Tutorials from Install to Publish and More Page 104 
 

Notice the placement of the closing </a> tag within the code. Choose the method you use depending on 
how you want the bookmarked text to display. 

When you bookmark an empty location, the bookmark is indicated in Design view by a bookmark icon 
when Show and Paragraph Marks are both selected under Formatting Marks on the View menu. 

 

Figure 86 - Bookmark formatting mark in Design View 

To create a bookmark  
Step 1 - Open the web page in either Design view or Code view.  

Step 2 - Select the text to which you want to assign a bookmark OR place your cursor in an empty space 
next to the text you want to use as a bookmark.  

Step 3 - Insert >  Bookmark or CTRL + Shift + G.   

 

Figure 87 - Screenshot Insert Bookmark menu item 

Step 4 - In the Bookmark dialog box, under Bookmark name, type a name for the bookmark. If you have 
selected more than one word, the default for Expression Web is to use the selected text separated with 
an underscore. 
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Figure 88 - Bookmark dialog box 

To remove a bookmark  
Step 1 - Open the web page in either Design view or Code view.  

Step 2 - Insert >  Bookmark or CTRL + Shift + G  

Step 3 - Under Other bookmarks on this page, click the bookmark you want to delete. Click Clear. 

 

Figure 89 - Clear Bookmark 

Tip - You can also remove a bookmark that's selected in your web page by pointing to the tag that 
appears in the Quick Tag Selector bar at the top of the web page, and then click the arrow next to the 
tag and select Remove Tag.  
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Figure 90 - Quick Tag Selector drop down menu 

HTML Links - the target Attribute 
The target attribute specifies where to open the linked document. If you want your hyperlink to open in 
a new window the html code would look like this: 

<a href=http://www.expression-web-tutorials.com/ target="_blank">Home</a> 

Picture hyperlinks 
A graphic image can also serve as a hyperlink, linking to another page or a larger image. Hyperlinks on a 
picture are not always apparent, however, when your viewer positions the cursor over the hyperlinked 

image the pointer changes appearance. The pointer will turn into a little hand .  

• The entire picture can be a hyperlink which allows the site visitor to click any part of the picture 
to display its destination. Typically buttons on a page would be this type of hyperlink or a 
thumbnail image which opens to a larger image. 

• You can also assign one or more hotspots (hyperlinked regions) to a picture which is then called 
an image map. Your site visitor can then click a certain area of the image map to display the 
corresponding page. For more information on image maps, consult the User Guide under the 
Help menu. 

To Create or modify a hyperlink 
With your web page open, in Design view or Code view, do one of the following: 

1. Select the text or image you want to use as the hyperlink. If no text or image is selected, the 
destination URL is displayed as the hyperlink text.  

2. To modify an existing hyperlink, put your cursor anywhere in the hyperlink. 

http://www.w3schools.com/TAGS/tag_map.asp
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3. Using either the Common or the Standard toolbar, click Insert Hyperlink icon . 

In the Insert Hyperlink or the Edit Hyperlink dialog box, do the following: 

 

Figure 91 - Edit Hyperlink dialog box. 

• Text to display – Type or edit the text you want to display as the hyperlink. 
• ScreenTip - click ScreenTip. In the Set Hyperlink ScreenTip dialog box, type the text you want to 

display, and click OK. The text you typed will display in a floating box when a user's pointer is 
over the hyperlink. 
NOTE: There is a bug in EW4 that once you click OK, will navigate away from EW. You will need 
to return to EW to finish the process. 

 

Figure 92 - Set Hyperlink Screen Tip dialog box 

1. Existing File or Web Page allows you to link to a web page or a bookmark on a web page. Select 
this option and do one of the following: 

o In the Address box, specify the web page or, to locate the page, do one of the following: 
 Browse through the folders and files on your site and select the page/folder you 

wish to link to. 
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 To browse through the pages and files you've recently visited in Windows 
Internet Explorer, either select Browsed Pages or select an item from the 
Address drop-down menu.  
NOTE:  If IE is not your default browser, copy and paste the url you wish to use 
in the address box. 

 To browse through files you've recently edited in Microsoft Expression Web, 
select Recent Files. 

 To browse the World Wide Web using Internet Explorer, to the right of the Look 
in box, click Browse the Web. In your web browser, browse to the page that you 
want to link to, and then press ALT+TAB to switch back to Expression Web. The 
location of the page you visited is displayed in the Address box. 
NOTE:  If IE is not your default browser, copy and paste the url you wish to use 
in the address box. 

o To link to a bookmark on the page you selected, click Bookmark, and then in the Select 
Place in Document dialog box, under Select an existing place in the document, click the 
bookmark that you want to use as the destination. 

2. Place in This Document allows you to link to a bookmark on the current web page. Select this 
option and then, under Select a place in this document, click the bookmark you want to use as 
the destination. 
NOTE:  There is a known bug where if you have Internet Explorer open to a particular website, 
the link to that site will be used as your bookmark instead of the link you intended. 

3. Create New Document allows you to create a new page at the same time you link to that page. 
Select his option, then do the following: 

 

Figure 93 - Create New Document and Insert Hyperlink dialog box 

o In the Name of new document box, type the name of the file you want to create and 
link to. The new document will be created in the folder you are currently in.  

o If you want to create a document in a different location, under Full path, click Change, 
browse to the location where you want to create the file, and then click OK. This can be 
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very useful when you are working on menus and need pages that do not yet exist. Just 
remember to go back and edit the page. 

o Under When to edit, specify whether you want to edit the file now or later. 
4. E-mail Address allows you to link to an E-mail address. Select this option and do the following: 

 

Figure 94 - E-mail Address and insert Hyperlink dialog box 

o In the E-mail address box, type the e-mail address. 
o In the Recently used e-mail addresses box, select an e-mail address. 

 
Optional: If you want to set the subject heading of the e-mail message, in the Subject 
box, type the subject. Be aware that some web browsers and e-mail programs may not 
use the subject heading that you set. 
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5. Target Frame - This option is available only for frames pages and is not available if the 
destination of the hyperlink is to an e-mail address. The default target frame is to open the 
hyperlink in the same browser window as the current page. Clicking the Target Frame button, 
will open a dialog box and allow you to specify the Target Setting as New Window which will 
add _blank to the hyperlink code and cause the link to open in a New Window when clicked. 

 

Figure 95 - Target Frame dialog box 

 

Useful Tips 
• Always add a trailing slash to subfolder references. If you link like this: 

href="http://www.expression-web-tutorials.com/ew4", you will generate two requests to the 
server, the server will first add a slash to the address, and then create a new request like this: 
href="http://www.expression-web-tutorials.com/ew4/". 

• Named anchors are often used to create "table of contents" at the beginning of a large 
document or page. Each chapter within the document is given a named anchor, and links to 
each of these anchors are put at the top of the document. 

• If a browser does not find the named anchor specified, it goes to the top of the document. No 
error occurs. 

Additional Resources 
• HTML Links by W3schools 
• Hyperlinks by Media College 

  

http://www.w3schools.com/HTML/html_links.asp
http://www.mediacollege.com/internet/html/hyperlinks.html
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Publishing Your Web Site  
NOTE: There are some major changes in the User Interface of Expression Web 3.0 and 4.0 

New Publishing Features to Expression Web 4.0 include: 

• The ability to exclude complete folders from publishing rather than just files.  
• The ability to easily Publish Current Page 

 

To mark files or folders that you do not want to publish 

Do one of the following: 

• In the Folder List panel, right-click the file or folder that you do not want to publish, and 
then click ‘Exclude from Publishing.’ If you mark a folder as exclude from publishing, ALL 
files within that folder are also marked ‘Exclude from Publishing.’ 

• In the left-hand pane of Publishing view, right-click the file that you do not want to 
publish, and then click ‘Exclude from Publishing’. 

 

Figure 96: Exclude from Publishing 

 

Figure 97: Folder/Files Excluded from Publishing 
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Publish Current File 

There is now an option to ‘Publish Current File.’ You must have a page open for this option to be 
available. To publish the current file, do one of the following: 

• From the ‘Site’ menu, click ‘Publish Current File.’ 
• From the keyboard Cltrl + Shift + U 

• From the ‘Standard’ toolbar, click the ‘Publish Current File’ icon   

Migrate Existing File Definitions to Expression Web 4 
 

Each time I install a new version of Expression Web, I always 
have to re-enter all of the publishing information for each site. 
Wouldn’t it be nice if I could just copy them for one version to 
another? Now you can migrate existing file definitions from 
version 3 to version 4. You will need to copy the SiteData 
directory (or just certain folders from that directory) 

C:\Users\UserName\APPDATA\Microsoft\Expression\Web 
3\SiteData 

to the equivalent Web 4 location which for me is 

%APPDATA%\Microsoft\Expression\Web 4\SiteData 

I copied the folder for one of my Expression Web 3 sites that I 
had not yet set up in Expression Web 4 and it works perfectly. 
Quite a time saver! 

 

Publishing Your Website 

Now that you have finished designing your site you will need to publish it for the world to see. 
The screenshots for this tutorial were done with a system running Windows Vista Ultimate and 
Expression Web 4.0. Yours may look slightly different. Expression Web supports several 
different publishing scenarios.  

Step 1: Open the website on your computer in Expression Web. Make sure you have saved all 
of your pages. You will receive a warning if you have not once you start the publishing process. 
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Step 2: If you didn’t set the options for your site while developing your site, check your settings 
before attempting to upload/publish. Site > Publishing Settings > Add/Edit . 

FREE Setting up Expression Web Ebook by Tina Clarke. 

Step 3: Recalculate Hyperlinks: Tools > Recalculate Hyperlinks.  

 

Figure 98 - Recalculate Hyperlinks 
 

Step 4: Click Site on the menu, select Publishing 

 

 

Figure 99 - Site > Publishing 

Step 5: If this is the first time you have published this site, you will receive the message 'Add a 
publishing destination.' Click the message and the Connection Settings dialog box will appear.  

http://any-expression.com/expression-web/ebooks/setting-up-expression-web-ebook.htm
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There are several things to do on the dialog box that pops up.   

1. "Name" - Type the name of the site, i.e., Genealogy Web Creations. 
2. "Connection Type" - select FTP, SFTP, FTPS, FrontPage Server Extensions, WebDav, or 

File System.   
3. "Location" - type the Internet address, including the protocol, of the remote website 

that you want to publish folders and files to — for example, ftp://www.your-
domain.com OR http://www.your-domain.com. 

4. "Directory" - the folder/directory on the server you are publishing the files to. 
 
NOTE: In the case of 1and1 Linux servers, it would be whichever directory you have 
pointed that domain to. 
 
NOTE: In the case of BlueHost, you may enter your domain name or the IP address of 
your server. Enter your ftp directory. If this is your main domain (the domain you 
opened your account with) enter public_html. If you have pointed your main domain to 
a subfolder, enter public_html/name-of-folder.  If you are publishing to an addon 
domain, you would type public_html/addon-domain-directory.  
 
Make sure you check with your particular host as to the path to publish your files too. 

5. "Credentials User name" - your User Name 
6. "Credentials Password" - your password 

 

 

Figure 100 - Connection Settings 

Click 'Add.' At this point you are automatically connected to your server. 
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If you have already set up your 'Publishing Settings' you will receive the message 'Connect to 
current publishing destination.' You can click the message OR you can use the Connect To 
button on the Site View tab. 

 

Figure 101 - Screenshot Publishing Bar 

Step 6: You will see your website (on your computer) in the left window.   

 

Figure 102 - Local and Remote Website 

 
Depending on what you are trying to do: 

Choose from the View dropdown which files you want to publish. There are three arrows 
between the windows.  If you want to move just a file or two, you can highlight it, then click the 
arrow to copy just that file or files. 



Expression Web 4.0 Tutorials from Install to Publish and More Page 116 
 

 

Figure 103 – Publishing corresponds with 
center bar in previous image 

The top arrow 'Publish files to the destination site' is used most often. It publishes your choice 
of files from your computer to your server. Keyboard shortcut is Ctrl + Alt + P. 

The middle arrow 'Get files from the destination site' is used if you happen to lose your site on 
your computer or damage the files, you could use this to download the site or a file from server 
to your own computer. Keyboard shortcut is Ctrl + Alt + G. 

The bottom double arrows 'Synchronize files,' compares the two sites and moves the data back 
and forth until they match.  Use this with caution. Keyboard shortcut is Ctrl + Alt + Y. 

OR 

Step 7: Using the ‘Standard’ toolbar, click the button you wish for the appropriate publishing 
operation. 

 

Figure 104: Standard toolbar publishing options 

From Left to Right:  

• Publish the current File 
• Publish all  changed files to your site 
• Publish all files to your site 
• Get all changed files in your site 
• Get all files in your site 

Once you start the publishing process, you will see your files being transferred. When complete, 
you will get a message that your file is finished uploading.  
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Figure 105 - Successful Publish 

You can also choose to 'view your publish log files.'  

The next time you publish your site; this process will compare the server site with what is on 
your computer. If you select ‘Publish all changed file’ only those files that have changed will be 
published to the server. No files will be deleted. 

If you have problems publishing, check the following:  

• Did you type your UserID and password correctly?  Remember it’s caSE seNSitiVE, so 
must be exactly what you were given by your host. 

• Did you type the ftp or http address correctly?  
• If you have a Firewall installed, did you give Expression Web the permissions it needs to 

publish? 
• Spaces in file names MAY cause problems in uploading files. It is best NOT to use them. 

Use a hyphen or underscore to separate the words publishing-website.html or 
publishing_website.html NOT publishing  website.html. 

Once you have finished publishing your site, check online to make sure things are working as 
you expect them to.  
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How to back up your local website on your 
hard drive 
This question frequently comes up on various mailing lists. “How can I publish my website on 
my hard drive to a backup location on my hard drive?” Unlike Windows Explorer, there is no 
Recycle Bin in Expression Web. If you inadvertently delete your website or pages within the 
site, you are going to be in a Restore situation. 

Back up your website using Expression Web 4.0 

Step 1: Open up the site you wish to back up in Expression Web. 

Step 2: Recalculate Hyperlinks: Tools > Recalculate Hyperlinks. 

 

Figure 106 - Recalculate Hyperlinks 

Step 3: Choose Site > Publishing Settings. 

 

Figure 107 - Site > Publishing Settings Menu 
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You can also select 'Publishing' > 'Publishing Settings' (upper right on Site View). 

Step 4: In the 'Site Settings' dialog box, click the 'Publishing' tab. The current publishing 
destination will show as the default.  If you have already published this site to your web hosting 
account, click 'Add.' 

 

Figure 108 - Site Settings > Publishing Tab 

Step 5: Choose 'File System' from the 'Connection Type' dropdown menu. 

Step 6: In the 'Connection Settings' dialog box, do the following: 

1. "Name" - Type the name of the site i.e., EW Tutorials  BACKUP. 
2. "Location" - Type the folder name where you want the backup published  — for 

example, C:\Users\Patricia Geary\Documents\My Web Sites\ew-tut-backup OR browse 
to the empty web you created beforehand in preparation for backing up.  

3. Click 'Add.' 
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Figure 109 - Connection Settings 

Step 7: Select the newly created backup location from the Connect To dropdown menu 

 

Figure 110 - View Connect To Bar 

If the folder does not currently exist, you will be prompted to create it. Click 'Yes' and the 
website will be created for you. 

Step 8: You will see your website (on your computer) in the left window, and the newly created 
backup website (also on your computer) will be on the right hand side. It will be empty if this is 
the first time you are backing up your site. 
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Figure 111 - Publishing Window 

Once connected, click the 'View' dropdown and select one of the following: 

• Selecting either of the 'All Files' views will publish all files.  
• Selecting the 'Changed Files' view will publish just the changed files. 

Depending on what you are trying to do: 

Choose from the View dropdown which files you want to publish. There are three arrows 
between the windows.  If you want to move just a file or two, you can highlight it, then click the 
arrow to copy just that file or files.   

NOTE: None of the arrows will be available to you until you select a file to publish. 

 

Figure 112 – Publishing 

If this is the first time you have backed up your site, do one of the following: 

• One the keyboard, use Ctrl + Shift + A 
• From the Site menu, select ‘Publish All Files to “Name of Web”’ 

• From the Standard or Common toolbar, select the icon for ‘Publish all files in your site’  
• Hold down the Shift key and highlight the first file/folder on the list, then highlight the last 

file/folder on the list. This will highlight all of the files and folders and the top arrow will now be 
blue. Select it, and all files will be published to the backup directory 
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Once you start the publishing process, you will see your files being transferred. When complete 
you will get a message that your file is finished uploading. 

 

Figure 113 - Successful Publish 

  



Expression Web 4.0 Tutorials from Install to Publish and More Page 123 
 

Expression Web 4.0 Add-ins 
 A new extensibility model will allow you to create add-ins much more easily using html, css, javascript 
and a manifest file (xml).  Anna Ulrich has an article on how to create add-ins for Expression Web 4 at 
Easily create an Add-in for Expression Web 4 with the Add-in Builder. 

Jim Cheshire also has a tutorial on Creating an Expression Web Add-in and later this year will be 
releasing and EBook  

What is an Expression Web Add-in?  

An Expression Web Add-in, is an external software package that provides additional or enhanced 
functionality within Expression Web 4. One of the first add-ins released is from WebAssist. 

How to Install Add-ins? 

Step 1: Launch Expression Web 4.0. Go to 'Tools' on the menu and select 'Add-Ins.' 

 

Figure 114 - Tools Add-ins menu 

Step 2: In the 'Manage Add-ins' dialog box click the 'Install' button. 

NOTE: If this is the first Add-in you have installed, the list will not yet be populated. 

http://blogs.msdn.com/b/xweb/archive/2010/06/07/easily-create-an-add-in-for-expression-web-4-with-the-add-in-builder.aspx
http://www.jimcobooks.com/articles/061130/
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Figure 115: Manage Add-ins dialog 

Step 3: Browse to the location on your computer where you downloaded the Add-in. Click 
'Open.' The add-in will end with the file extension .xadd. The add-in will be installed. 

Step 4: Once installed, you will be asked if you want to enable the add-in. The screen will 
give you all of the information on the particular add-in you are installing. Click 'Yes.' 

 

Figure 116: Enable Add-in 

Step 5: If you once again click 'Tools' on the menu bar and select 'Add-ins' you will see the 
list has now been populated with your first add-in. 
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Figure 117: Manage Add-ins list 

Step 6: To use your Add-in go to 'Panels' and select the Add-in. In this case Payment 
Buttons for PayPal. 

 

Figure 118: Add-in menu item 

It is as simple as that.  

In the coming weeks and months, watch for more and more add-ins to become available. 
Here are a few that are currently available. 
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Expression Web Free Add-ins 

• Payment Buttons for PayPal by WebAssist. Create, add, and manage PayPal 
buttons for your products. 

• SlapShot for Expression Web 4 SlapShot is based on the SnapShot panel, in that 
you can easily preview a page without loading a browser, however SlapShot extends 
the features of SnapShot by including full ActiveX support (Silverlight®, Flash®, and 
so on), as well as interactivity within the page (including navigation).  

• Expression Web Add-ins by Ian Hayes 
o Copyright Notice Add-In for Expression Web V4 - This add-in creates a 

JavaScript based copyright notice that always updates to the current year and 
also creates a static notice, without the year, for the very small percentage of 
users that don't have JavaScript enabled.  

o Sub/Sup Text Add-in for Expression Web 4 - The add-in puts two new buttons 
on the "Standard" toolbar for <sub> and <sup> text..  

o Code Comment Add-In for Expression Web 4 - This add-in adds the comment 
CSS functionality and provides three new icons on the "Standard" toolbar  

o Close All' Add-In for Expression Web V4 allows you to close all open pages in 
EW with one click. It puts an icon on both the Standard and Common toolbars  

o WordPaste Add-In – Allows you to paste clean HTML from Microsoft Word™ 
documents. 

o AddFeed Add-In –  allows you to easily display a Twitter or RSS feed on your 
site. 

o 'Attach-JS' Add-In – This add-in adds an item to the 'Insert' menu that allows 
you attach a javascript file to your page. It lets you select the file and, if the 
file is outside the current web, copies it to the web when you've selected the 
file. 

o Meta Tag snippets for xWeb V4 SP2 - adds two groups of snippets for normal 
meta tags -  Meta and Robots Meta Tags. 

o HTML5 Placeholder - A simple add-in that adds the HTML5 'placeholder.’ 
o WinPop add-in for Expression Web V4 - WinPop creates 'accessible pop-up 

windows'. By accessible I mean that they can be read by screen readers and 
continue to work if a user has JavaScript turned off. 

• Insert Bing Map Add-in 
• Search for Bing by WebAssist - Search for Bing gives Expression Web users the 

ability to integrate a powerful Bing site search into any website. Whether you are 
new to Expression Web or an experienced developer Search for Bing is a great way 
to add search to your website. It is easy-to-use, quickly implemented and will provide 
your website users with the ability to find what they are looking for, fast.  

o Example: Search Expression Web Tutorials  NOTE: Your site needs to be 
already indexed for this to work. 

•  

Expression Web 4.0 Commercial Add-ins 

• Advanced CSS Drop Down Menu Expression Web by Ajatix. You can see a sample 
of this menu used on my FREE Ocean Template. 

• Pure CSS Menu Expression Web by Ajatix 

http://www.webassist.com/expression-web-add-ins/payment-buttons-for-paypal/?WAAID=861
http://gallery.expression.microsoft.com/en-us/slapshot
http://www.ew-resource.co.uk/v4addins.aspx
http://gallery.expression.microsoft.com/en-us/CopyrightNotice
http://gallery.expression.microsoft.com/en-us/SubTextAddIn
http://gallery.expression.microsoft.com/en-us/CodeCommentAddIn
http://gallery.expression.microsoft.com/en-us/CloseAllAddin
http://gallery.expression.microsoft.com/en-us/WordPaste
http://gallery.expression.microsoft.com/en-us/addFeed
http://gallery.expression.microsoft.com/en-us/AttachJS
http://gallery.expression.microsoft.com/SP2MetaTags
http://gallery.expression.microsoft.com/HTML5Placeholder
http://gallery.expression.microsoft.com/WinPop
http://gallery.expression.microsoft.com/en-us/BingMapAddIn
http://www.webassist.com/expression-web-add-ins/search-for-bing/?WAAID=861
http://www.expression-web-tutorials.com/bing_search.html
http://www.ajatix.com/css-drop-down-menu/expression-web-add-in.html
http://www.expression-web-tutorials.com/ocean/
http://www.ajatix.com/pure-css-menu/expression-web-add-in.html
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• Lightbox Expression Web by Ajatix - A tutorial on how to add the lightbox to your site 
and an example gallery. 

• Horizontal Menu Advancer by CSSMenuTools 
• Accordion Menu Advancer by CSSMenuTools 
• LightBox Advancer by CSSMenuTools 
• Vertical Menu Advancer by CSSMenuTools  
• SalesCart Express by ShoppingCart - A fully complete Ecommerce solution and 

shopping cart add-in that you invoke directly from Expression Web and the toolbar 
allowing you to quickly add products and build a complete online storefront.  Free, 
fully functional 30-day trial is 100% convertible after 30 days.  

• SEO Tools for Expression Web 4 by expression extras. The SEO Tools for Microsoft 
Expression Web add-in helps you prepare your site and pages for Google, Bing, and 
other Internet search engines. Integrated with Expression Web, you'll have all the 
tools you need to help get your site and pages noticed. 

  

http://www.ajatix.com/lightbox/expression-web-add-in.html
http://www.cssmenutools.com/horizontal-menu-advancer-expression-web.html
http://cssmenutools.com/accordion-menu-advancer-expression-web.html
http://cssmenutools.com/lightbox-advancer-expression-web.html
http://cssmenutools.com/vertical-menu-advancer-expression.html
http://gallery.expression.microsoft.com/SalesCart
http://www.expressionextras.com/products/seo_tools_expression_web_3.htm
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Learning HTML - HyperText Markup 
Language  
Microsoft Expression Web is a professional Web design tool that is designed to create 
standards-based Web sites. The following skills are required in order to use Microsoft 
Expression Web successfully:  

• XHTML / HTML  
• Cascading Style Sheets (CSS) for styling page elements  
• CSS for page layout  

You can read more about Prerequisites for Using Microsoft Expression Web from Microsoft. 

What is HTML?  
HTML stands for Hyper Text Markup Language and is a language for describing web pages. 
HTML is a markup language rather than a programming language and makes use of HTML 
tags to structure the content of your web pages. 

Is there a difference between HTML and XHTML? XHTML is more choosy than HTML in that 
there are some elements that absolutely must appear in the XHTML markup, but which may be 
omitted if you’re using HTML 4 and earlier versions. If you would like more information on 
these differences see: 

• HTML vs XHTML by W3schools 
• HTML Versus XHTML by SitePoint 

By default, Expression Web uses XHTML markup! 

If you want to successfully work with Expression Web AND be able to troubleshoot your pages, 
you will need a good working knowledge of the basic HTML tags you will use to build your web 
pages. 

HTML Tags  
HTML tags are keywords surrounded by angle brackets like <html> and normally come in 
pairs <html> </html>. The first tag of the pair is the opening or start tag, the next one the 
closing or end tag. 

Listed below are ONLY a few of the tags you will need to learn about in order to work on 
structuring your web pages. 

http://support.microsoft.com/default.aspx?scid=kb;en-US;2511858
http://www.w3schools.com/html/html_xhtml.asp
http://reference.sitepoint.com/html/html-vs-xhtml
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<body> tag 

The <body> tag defines the document's body and contains contains all the contents of an HTML 
document, such as text, hyperlinks, images, tables, lists, etc. Both an opening and closing tag are 
required <body> </body>. Expression Web creates this tag is for you when you create a new 
page. 

<div> tag 

The <div> tag defines a division or a section in an HTML document. Both an opening and 
closing tag are required <div> </div>. More details on HTML <div> tag 

paragraph <p> tag 

The <p> tag defines a paragraph. By default, browsers automatically add some space (margin) 
before and after each <p> element. You can modify the default styling by changing the margin 
style rules using CSS. Both the opening and closing tag are required <p> </p>. 

heading <h1> to <h6> tags  

The <h1> to <h6> tags are used to define HTML headings. <h1> defines the most important 
heading. <h6> defines the least important heading. Both an opening and closing tag are required 
<h1> </h1>. Read Heading Tag Structure by James Huggins. 

Heading tags are NOT used to style your page but to provide structure to your page. 

<ul> tag 

The <ul> tag defines an unordered or bulletted list and is used with the <li> tag. Both the 
opening and closing tag is required <il> </ul>.  

Unordered lists are used to create both vertical and horizontal navigation. 

<ol> tag 

The <ol> tag defines an ordered list. An ordered list can be numerical or alphabetical. Use the 
<li> tag to define list items. Both the opening and closing tag is required <ol> </ol>.  

<li> tag 

The <li> tag defines a list item and is used in both ordered (<ol>) and unordered (<ul>) lists. 
Both the opening and closing tag is required <li> </li>. 

http://www.expression-web-tutorials.com/div-containers.html
http://www.genealogy-web-creations.com/heading-tags.html
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<img> tag 

The <img> tag defines an image in an HTML page and has two required attributes: src and alt. 
Images are not technically inserted into an HTML page, images are linked to HTML pages. The 
<img> tag creates a holding space for the referenced image. The img tag must be properly closed 
<img /> The width and height of the image should also be included. 

<img alt="Screenshot Include filename." src="images/code-snippet-filename.jpg" width="278" 
height="49" /> 

<a> tag 

The <a> tag defines an anchor. An anchor can be used in two ways: 

• To create a link to another document, by using the href attribute 
• To create a bookmark inside a document, by using the name attribute 

The <a> element is usually referred to as a link or a hyperlink. The most important attribute of 
the <a> element is the href attribute, which indicates the link’s destination. 

<a  href="div-containers.html">HTML div tag</a>  

Summary 
In summary, the tags listed above are only a few of the ones you will need to structure your 
HTML document. You can see a listing of the various tags HTML 4.01 / XHTML 1.0 Reference 
at w3schools and Elements by SitePoint 

Once you learn the basics of HTML tags, you will find Expression Web much easier to use and it 
will go a long way towards helping you troubleshoot problems. 

Learning Resources 
HTML Coding - Hypertext Markup Language 

• W3Schools  
• HTML Document Structure  
• HTML Tutorial - Table of contents  
• A Bare Bones Guide to HTML - The Bare Bones Guide to HTML lists every official HTML tag in 

common usage, plus Netscape and Microsoft extensions. Version 4.0 of the Guide is designed to 
conform to the HTML 4.0 specification. For official information on the development of HTML, 
see the World Wide Web Consortium's HTML activity statement.   

• HTML Basic Tutor - This is a website targeting small business owners, beginner web designers 
and hobbyist web site owners. The theme of the site is to promote good web design practices 
and coding by implementing the recommendations of the W3C (World Wide Web Consortium) 

http://www.expression-web-tutorials.com/anchor-tags.html
http://www.w3schools.com/tags/default.asp
http://www.w3schools.com/tags/default.asp
http://reference.sitepoint.com/html/elements
http://www.w3schools.com/html/default.asp
http://www.genealogy-web-creations.com/html-document-structure.html
http://www.html.net/tutorials/html/
http://www.werbach.com/barebones/download.html
http://www.htmlbasictutor.ca/
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in a fashion that a person with little or no knowledge of web design can learn from.  Each HTML 
tutorial is written with the HTML beginner in mind. Currently,   

• HTML Code Tutorials - Free Reference Guide for Help with HTML Tags Including Form, Frames, 
Tables, and more! 

• HTML Dog  - Very useful HTML and CSS tutorial place, teaching You everything step by step - 
best practices, standards and code with “easy to understand” example. 

• Your HTML Source - Teaches you not only how to create your very first homepage, but how to 
style it with CSS, add spice with Javascript and create it accessible and SEO friendly.  

XHTML - EXtensible HyperText Markup Language  

• XHTML Tutorial - XHTML is a stricter and cleaner version of HTML and is the default used by 
Expression Web. 

• NYPL Online Style Guide - Created for use by the New York Public Library, it has some excellent 
information for your use. 

Your next project should be learning the basics of cascading style sheets and how to use them to 
style the tags you have just learned to use. 

  

http://www.htmlcodetutorial.com/
http://htmldog.com/
http://www.yourhtmlsource.com/
http://www.w3schools.com/xhtml/default.asp
http://www.nypl.org/styleguide/index.html
http://www.expression-web-tutorials.com/css-basics.html
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CSS Basics  
Much of the content of this page is based on the User Guide in Expression Web. You can access 
the User Guide by selecting Help from the menu, then User Guide.   

What is CSS?  
CSS stands for Cascading Style Sheets. A style is a set of formatting characteristics that are 
defined in a cascading style sheet (CSS) and define how to display HTML elements. You can 
apply styles to content in a web page, including text (individual characters or entire paragraphs), 
graphics, layers, tables, and even to the body of the entire web page. Styles enable you to 
efficiently reuse a set of properties and values without having to set the properties every time you 
want to use them. 

They also make it much easier to maintain a website. If you decide you want the page 
background to be green instead of blue, one change in the style sheet will make the change on 
every page the style sheet is attached to. 

Cascading Order 
What style will be used when there is more than one style specified for an HTML element?  

Styles are read in three ways: browser default, style sheets (internal in the <head> or external via 
@import or <link>) and inline styles. The default priority is as follows, where number four has 
the highest priority:  

1. Browser default  
2. External style sheet  
3. Internal or Embedded style sheet (inside the head tag)  
4. Inline style (inside an HTML element) 

So, an inline style (inside an HTML element) has the highest priority, which means that it will 
override a style declared inside the <head> tag, in an external style sheet, or in a browser (a 
default value). 

Example of an inline style which tells the browser to render the content of this paragraph as red:  

<p style="color:red">This is a line of content.</p>   

Types of Styles 
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A style rule has two main parts: a selector and one or more declarations. The style can have a 
class, element, or ID selector. The above example uses an element for the selector.  

A style is defined by its rule set, which consists of a selector, followed by a block of property 
declarations that appear between a left curly brace ({) and right curly brace (}). 

 Each type of style is distinguished from the other style types by its selector;  

• a period (.) precedes the selector for a class-based style;  
• a number sign (#) precedes the selector for an ID-based style;  
• and the selector for an element-based style consists only of an HTML element, such as 

H1 which is shown in the drawing above. 

Element selectors  

Use an element selector to define a set of properties that you want every instance of a particular 
HTML element to use in a web page. For example, to create a margin of 25 pixels around all 
paragraphs (content surrounded by <p> tags) in your web page, you create a style that uses the p 
element as its selector and contains declarations for margin properties, as shown in the following 
code.  

Example of a rule set for an element selector:  

p { margin-left: 25px; margin-right: 25px }  

Class Selectors 

Use a class selector to define a set of properties that you want to use on one or more items in a 
web page. If you ever want to modify the style, you can edit the style's rule set and every item 
you've applied the style to will automatically reflect the changes.  

In the following example, "sidebox" is the style's selector, and "border: #cccccc 2px solid; " is 
one property declaration, followed by a second property declaration.  

Example of a rule set for a class selector:  
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.sidebox { border: 2px solid #CCCCCC; margin: 0px 5px 3px 5px; 
padding: 0px 3px 15px 3px; background: #FFFFFF; color: #000000; 
font-size: 85%; }  

Example of a class selector applied to a <div>tag:  

<div class="sidebox>  

The Testimonials box on the left is the result.  

ID selectors 

Use an ID selector when you want to define a set of properties for a single item or block of 
items that you want to distinguish from all other content in one or more web pages. Use an ID 
selector when you want to style a single HTML element in a web page. 

Example of a rule set for an ID-based style: 

#footer { border-top: 2px solid #564c66;  text-align: center; 
font-size: 80%; padding: 10px 0px; margin-top: 5px; margin-
bottom: 5px; }  

Apply this CSS rule to a single HTML element.  

<div id="footer">  

Inline styles  

Use an inline style when you want to define a set of properties for a single item or block of items 
in a web page and don't want to reuse that style. Unlike ID, element, and class selectors, whose 
properties are defined in either the head section of a web page (internal CSS) or in an external 
CSS file, the properties of an inline style (or inline CSS) are defined directly in the HTML 
element you want to use the style. 

<p style="font-weight: bold; font-style: italic; color: 
#003A73">  

which would render this: 

A sentence that looks like this. 
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How to Copy and Paste Text so the Code is 
Clean 
Now that you have learned how to use Expression Web and hopefully have learned the basics of writing 
HTML and CSS, you can start adding your content. If you have content from a previous website or from 
an MS Word document that you want to copy and paste into your cleanly coded new web site, be 
warned that unless done correctly, you will be copying all of the old styles applied to the content you 
care copying. 

You could copy and paste your content into a plain text editor like Notepad first but you will lose any 
hyperlinks that are part of that code. A much quicker (and better) way would be to copy the text from 
the Word document or web page by highlighting the text > right click and select Copy. 

Next, with your web page open in Expression Web, place your cursor where you want the content to 
appear > select Edit > choose Paste Text OR right click and select Paste. 

The Paste Text dialog box will appear > select Plain text making sure the Preserve hyperlinks box is 
checked. If you have several paragraphs of text select Normal paragraphs without line breaks.  

 

Figure 119 - Paste Text dialog box. 

This process will remove any styles attached to the text from the document you copied from. Any style 
rules within your style sheet for the <p> tag should automatically be applied to the text you just pasted. 

The other selections from the Paste Text dialog are explained below: 

Select this  To do this  

Plain text  Remove all formatting, replace line breaks with spaces, and paste the selection as 
plain text. 
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One <pre> formatted 
paragraph  

Paste the text into a preformatted text tag set (<pre></pre>), which maintains all line 
breaks in the text. 

Many <pre> formatted 
paragraphs  

Paste each paragraph of text into a preformatted text tag set (<pre></pre>), which 
maintains all line breaks in the original text. 

Normal paragraphs with 
line breaks  

Paste the text into a paragraph tag set (<p></p>) and insert a line break tag (<br>) 
wherever a line break occurs in the original text. 

Normal paragraphs without 
line breaks  Paste the text into a paragraph tag set (<p></p>) and remove all line breaks. 

 

There is an even easier way to paste content into your Expression Web page. If you followed the earlier 
instructions for Setting Up Expression Web, this option will already have been set. If not, click Tools on 
the menu bar > Page Editor Options > General Tab. Make sure under Cut and Paste Options, that Show 
Paste Options Button is checked. 

Now, when you right click and select Paste, the Paste icon will appear . When you mouse over the 
icon a down arrow will appear. Click the down arrow and you will be presented with these selections: 

 

Figure 120 - Expanded selections for Paste Icon. 

Explanation of what each of the expanded selections do. 

Select this  To do this  

Keep Source 
Formatting  

Preserve the style formatting of the source document, regardless of the styles in the current 
Expression Web document. For example, if you copy Heading 2 text from a Microsoft Word 
document and paste it into a page in Expression Web, selecting Keep Source Formatting ensures 
that the Word Heading 2 style is applied. This is useful if Heading 2 is formatted differently in the 
two programs and you want to keep the Word formatting. 

Remove 
Formatting  Use this option to remove all formatting, and paste the selection as plain text. 

Keep HTML 
Only  

Use this option when you want Expression Web to render rather than display HTML tags. For 
example, if you copy an example of HTML code from a web browser (such as <i>text</i>) to a page 
in Expression Web, selecting Keep HTML Only ensures that the example code is rendered as italic 
text. 

Keep Text 
Only  

Use this option to remove all formatting, and paste the selection as plain text and set options in the 
Paste Text dialog box to control line breaking and white space. See the next table in the current 
topic for more information. 
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Create and Style a Data Table 
First, make sure that you have set up Expression Web using Tina Clarke's FREE EBook Setting Up 
Expression Web 4.0 

Create the Table 

Step 1: In ‘Design’ view, place the insertion point where you want to insert the table.  Do the following: 

• On the Menu > Table > Insert Table. NOTE: Do NOT Choose Layout Table. 

 

Figure 121 - Insert Table Menu 

• On the ‘Common’ or ‘Standard’ toolbar, click the Insert Table button, then use your pointer to 
draw the table; OR Click More Options. 

 

Figure 122 - Insert Table Button 

http://any-expression.com/expression-web/ebooks/setting-up-expression-web-ebook.htm
http://any-expression.com/expression-web/ebooks/setting-up-expression-web-ebook.htm
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• Set the properties that you want. 

 

Figure 123 - Insert Tables Dialog Box 

      Example Settings in Bold 

      Size: Set the number of Rows and Columns in your table. Rows: 25: Columns: 8. 
      Alignment: Set the horizontal alignment of your table. Default. 
      Float: Set the floating property of your table. Default. 
      Specify width: Set the width of your table. 100%. 
      Specify height: Set the height of your table. Do not tick.  Leave Blank. 
      Cell padding: Set the padding between cells. 1. 
      Cell spacing: Set the spacing within cells. 2. 
      Borders: Set the size and color of your table borders. 1 #999999  Tick: Collapse table border. 
      Background: Set the color or background picture you want as your table background. 

The following code was added to the head section of my page: 

<style type="text/css"> .style1 { width: 100%; border-collapse: collapse; border: 1px solid #999999; } 
</style> 
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Step 2: On the Manage Styles task panel, > Right Click the just created style1. > Choose rename class 
"style1." 

 

Figure 124 - Rename class style 

In the Rename Class Dialog box, Type "tombstones" or whatever you want to name the class. Make sure 
Rename class references in this page is ticked. 

 

Figure 125 - Rename Class Dialog Box 

You will see that the class has been renamed "tombstones," and the code for your table changed to: 

<table class="tombstones"> 

Step 3: From the ‘Manage’ or ‘Apply Styles’ task panel, > Click New Style. 
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In the New Style dialog box, type or select the following: 

 

Figure 126 - Create New Style Dialog Box 

Selector: Type .tombstone td 
Define in: Current page 
Block: vertical-align: top 
Border: sold 1px #999999 
Box: padding: 5px (untick: Same for all if you do NOT want the same amount of padding in the cells. 

You will see the style being created in the display area. 

Click OK, and the styles will be applied to the table cells. 

Step 4: If you want the top row to be a header row, > select the first row of data cells. > Right click > Cell 
Properties > Tick: header cell. > Click OK. 

You can create a new style for the header row by using the same method as described above, OR copy 
and paste the style you created for:   

.tombstones td { vertical-align: top; border: 1px solid #999999; padding: 5px; } 

changing the td to th. The default style will be centered and bold 

.tombstones th { vertical-align: top; border: 1px solid #999999; padding: 5px; } 

Example: Blank Styled Table 

http://www.expression-web-tutorials.com/ew3/table-example.html
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Style an Already Created Data Table 

If you have a data table already created, you can easily add styling to it. 

Step 1: Open the page with the table you wish to style in Expression Web. 

From the Quick Tag Selector, > Click <table>. 

From the Manage or Apply Styles task panel, > Click New Style. 

In the New Style dialog box, type or select the following: 

Selector: Type .prisoners 
Define in: Current page 
Border: solid 1px #999999 
Box: Uncheck:  Margins: Same for all Top: 10px Bottom: 10 px (this will add some spacing between the 
top and bottom of your table from other text. 
Position: width: 100% 

Make sure you have ticked Apply Style to document selection. 

The following code will be added to the head section of your page 

<style type="text/css"> .prisoners { border: 1px solid #999999; width: 100%; border-collapse: collapse; 
margin-top: 10px; margin-bottom: 10px; } </style> 

Step 3: From the ‘Manage’ or ‘Apply Styles’ task panel, > Click New Style. 

In the New Style dialog box, type or select the following: 

Selector: Type .prisoners td 
Define in: Current page 
Block: vertical-align: top 
Border: sold 1px #999999 
Box: padding: 5px (untick: Same for all if you do NOT want the same amount of padding in the cells. 

You will see the style being created in the display area. 

Click OK, and the styles will be applied to the table cells. 

Step 4: If you want the top row to be a header row > select the first row of data cells, > right click > Cell 
Properties > Tick: header cell > Click OK. 
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You can create a new style for the header row by using the same method as described above OR copy 
and paste the style you created for:  

.prisoners td { vertical-align: top; border: 1px solid #999999; padding: 5px; } 

changing the td to th. The default style will be centered and bold. 

.prisoners th { vertical-align: top; border: 1px solid #999999; padding: 5px; } 

Example: Fully Styled Data Table 

Points to Remember in Working with Tables 

• Consider the size of your table. Remember, not everyone has a high speed Internet connection. 
If you have a very large table, consider breaking it into smaller tables. 

•  If you want the table centered on the page, add auto for the left and right margins. 
• If you will be using the same styling on more than one table, move the table styles to an 

external style sheet where you can use them over and over again. 
• Using this method, your table code remains clean and your styles can be modified much more 

easily. 
•  You can add other style rules to the classes like font-size:small. 
• Make your tables accessible 

Sample Styled Accessible Table Using External Style Sheet 

  

http://www.expression-web-tutorials.com/ew3/example-table2.html
http://www.webaim.org/techniques/tables/data.php
http://www.expression-web-tutorials.com/ew3/example-table3.html
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